SQL Navigator 8.0 is now available!

Hi everyone,

We are pleased to announce the GA of SQL Navigator 8.0!

For all existing customers, SQL Navigator 8.0 contains new fixes and enhancements.


  • Support of Oracle 21c
  • Support of Windows 11
  • Support of Microsoft Server 2022
  • Support of noneditable keywords for Triggers/ Functions/Packages/Package Body
  • Support of the latest SQL Editor formatting and parsing syntax capabilities

Release notes:


Bug Fixes

  • SQL Navigator encounters slow loading times when attempting to open large objects containing more than 10,000 lines from a database. This issue has been observed across versions 7.6, 7.4, and 7.1.
  • Users are experiencing slowness when loading large size PL/SQL packages. This issue has been observed following an upgrade from SQL Navigator version 5.5 to 7.6.
  • Users are unable to extract a Data Definition Language (DDL) using the 'Use EDITIONABLE OR NONEDITIONABLE' parameter through SQL Navigator.
  • SQL Navigator is encountering slow loading times across various screens and functions, particularly when interacting with triggers.
  • The Zlib library has been upgraded from 1.2.7 to 1.2.13 in order to address issues related to the WhiteSource scan.
  • SQL Navigator displays the 'ORA-9000: invalid SQL Statement' error when a user tries to execute a query for creating a noneditable procedure.
  • Users are unable to compile extracted metadata using the Get Metadata function when the 'EDITIONABLE' clause is present in the Data Definition Language (DDL) definition.
  • SQL Navigator displays an error when users attempt to format code containing case statements in versions 7.5 and 7.4.
  • The update checker in SQL Navigator 7.4 displays inaccurate information when accessed through the Help > Check for Updates section.

Hello Gita,

thank you for this great news.
Is there a trial verison available so that we first could check it regarding our environment (server, teamcoding/tfs, ...) if there are no issues?


Hi Martin,
Feel free to use our Trial Product page to download the SQL Nav 8.0 trial edition:

1 Like

I just downloaded and installed the new version..

first impression is a big frown...

  1. hyperlinks from within a view still do not work.
  2. I open a existing DB package/function and it's all doublespaced.
  3. Creating a new function single spaced in 8.0 shows double spaced when viewed in 8.0 but is single spaced in 7.X
  4. Use the formatting tool adds even more blank lines to the code.. so start with 1 blank line; format code now you have 2 blanks lines, format code again, now you have 4 blank lines.. and so on... When viewing this from 7.X, additional lines are added to code.

I will update my list as I find more.. and I fear this will be a LONG list.


Yeah the double spacing issue will mean we will not roll this out to all our developers until fixed.
Example from 8.0


FUNCTION admp_ins_agent_ap_appl(

    p_applicant_data                IN      CLOB,

    p_add_document_ind              IN      VARCHAR2,

    p_messages                      OUT     ADMT_EXT_AGENT_AP_APPL_T)


    gv_other_detail                 s_error_log.other_detail%TYPE;


compared to 7.6.0 below


FUNCTION admp_ins_agent_ap_appl(
p_applicant_data IN CLOB,
p_add_document_ind IN VARCHAR2,
gv_other_detail s_error_log.other_detail%TYPE;

Not sure how that got through QA as it was obvious on the first object opened.


Hi everyone,
The team is working towards a hotfix patch to fix the double spaced editor issue. The patch is scheduled for availability next week. Thanks for the patience as we get the issue resolved and deliver a new build. We'll be in touch as soon as the patch is available.

1 Like

Hi everyone,
The Editor double space issue has been fixed with the latest SQL Nav 8.0 patch release. The installer can be downloaded from our portal page:

Thanks for your contributions on the other issues as well. They weren't included in the scope of this release and we'll be considering them for our future releases.

Joe, about the hyperlinks, would you be referring to describing views not working? If you can give us more details on that.

1 Like

If you open a view and use the left-ctrl key, it does not highlight the object so that you could click on it to open that object in a new window... This feature works fine if I'm in a function or package. And I'm pretty certain that this worked many years ago until it broke during some update. I think I submitted several tickets over the years and at one point, I just gave up. Seemed to me SQLNAV was dead and all development is going into TOAD :frowning:


Thanks Joe, we'll log the issue into the system so we can plan for its fix in the next release.

Dear Gita,

I'm working with the trial version right now. No issues so far. But.. 2 questions...

In the Release Notes I found "All the third party tools have been upgraded to their most latest versions. (SQLNAV-2354)".
Is there a list of these third party tools?
E.g. when I open "Teamcoding - Configure", the VCS entry is "Microsoft Team Foundation Server (2005-2013)". Can't find any newer version or an entry for Azure Dev Ops server.
Yet, it looks like it still is working with this older VCS selection.
And trying to export my queries result data I might choose "Excel 97-2010" format. Would expect MS Excel being one of these these third party tools.

Further, there is a point "Team Coding: The following options are not enabled in SQL Navigator under the Team Coding menu (SQLNAV-2448)" in the Known Issues section (Release Notes).
Is it possible to see the details behind SQLNAV-2448?
Not sure if this is similar to a (or exactly the) problem I reported in the past, which has been solved in the V7.7 beta (but never been released).


------ EDIT ------

After some more tests concerning teamcoding and TFS I found out, that I'm not able to check-in to the TFS. Teamcoding is working (check-in and check-out). But there is no history on our TFS.
This is working in V7.6 (except the random check-in bug which I reported some months ago and which had been solved in V7.7).
But now I'm no longer able to check-in with the latest version. I compared the settings of Teamcoding (...configure...settings). They are the same, as V8.0 took over all settings on the first start.