Toad World® Forums

SQL Navigator v. 6.0 and newer hangs


#1

Update

After some additional testing with multiple instances, our production instance loads without a problem but our other instance on a different server takes 2-3 minutes to load and makes it appear that the application is hung. Any suggestions of why version 6 does this but not version 5.5.

**

We are unable to use any version of SQL Navigator 6.0 or higher due to the application hanging while trying to connect to one of our Oracle instances.

Today I downloaded SQL Navigator 6.3.0.1833. I first tested using Oracle Client 9i and the application hung when connecting to our Oracle instance. Next I tried using Oracle Client 10g and the application hung as well while trying to connect to our Oracle instance. Next I tried using Oracle client 11g and once again the application hung while trying to connect to our Oracle instance.

We currently have users using SQL Navigator 5.5.3 and 5.5.4 and not having any issues connecting to our Oracle instance but have considered upgrading to version 6.

If anyone has any suggestions or ideas they would be greatly appreciated.

Thank you.

Message was edited by: rebelf


#2

Hi Rebelf,

Much appreciated if you could provide us more info. With the DB conneciton that you have issues with, pls do the following:

  • Start up SQL Navigator 6.x but do not establish any connection.
  • Run the SQL Tracker utility (.exe) which can be found in the program group of SQL Navigator. I have attached the screen shot of SQL Tracker for your referencde.
  • Click the 2nd button ont he tool bar to start capture all sql run by SQL Navigator.
  • Establish the DB connection in the Nav. Wait until the connection is done which might take a few mins as per your note.
  • Please save the output of all sql in the SQL Tracker to a text file. Please it to us.
    The file should give us more info on which sql takes too long…

Please do the same steps with connection the your production DB, so we can compare.

In version 6, the code editor is the new editor which more sql will be executed at the connection time, I would expect some sql might take a long time to complete.

Once you send in the sql tracker log, we will check it out for you.

Could you please also try the following:

  • Start up SQL Navigator, make sure no DB connection.
  • Go to the preference screen: View->Preferences, under Genereal->Session, uncheck the Show Code Editor option as the attached preference window screen shot.
  • Establish a DB connection to the Oracle instance that you have issues.
    Please let us know if this would make it quicker.

Thanks and regards,
Bruce
preference.jpeg


#3

Hi Rebelf,

Much appreciated if you could provide us more info. With the DB conneciton that you have issues with, pls do the following:

  • Start up SQL Navigator 6.x but do not establish any connection.
  • Run the SQL Tracker utility (.exe) which can be found in the program group of SQL Navigator. I have attached the screen shot of SQL Tracker for your referencde.
  • Click the 2nd button ont he tool bar to start capture all sql run by SQL Navigator.
  • Establish the DB connection in the Nav. Wait until the connection is done which might take a few mins as per your note.
  • Please save the output of all sql in the SQL Tracker to a text file. Please it to us.
    The file should give us more info on which sql takes too long…

Please do the same steps with connection the your production DB, so we can compare.

In version 6, the code editor is the new editor which more sql will be executed at the connection time, I would expect some sql might take a long time to complete.

Once you send in the sql tracker log, we will check it out for you.

Could you please also try the following:

  • Start up SQL Navigator, make sure no DB connection.
  • Go to the preference screen: View->Preferences, under Genereal->Session, uncheck the Show Code Editor option as the attached preference window screen shot.
  • Establish a DB connection to the Oracle instance that you have issues.
    Please let us know if this would make it quicker.

Thanks and regards,
Bruce
sqltracker.jpeg


#4

Bruceduong,

Thank you for the helpful information. Once I unchecked the “Show Code Editor after connection” I was able to establish a quick connection to the instance that was taking 3 minutes to load. What is it about the code editor that would cause the major slow down?

Thank you for the help.


#5

Unfortunately it still took 3 minutes to load the code editor in the instance of Oracle I am having issues with.


#6

Still having issues with Code Editor taking 3 minutes to load.


#7

Hi Rebelf,

Thanks for the update.

There are a few sql executions to populate the DB Explorer tree, plus to build up the list for the code completion…We will try to work on those areas to optimize, speed up the loading time, and will provide you a 6.4 beta build to verify soon.

Thanks and regards,
Bruce


#8

Hi Rebelf,

Could you please download our latest internal build from http://sqlnavigator.inside.quest.com/shares/sqlnavigator/sbin/beta/1873/sqlnav_6.4.0.1873-KX_beta.zip (download size ~ 87 MB).

Please install 6.4 Beta side by side with your 6.x production releases.

Much appreciated if you can let us know the issue with opening code editor has been fixed in this build. We are planning to release the next 6.4 beta build early next week to the Community, after we receive your feedback.

Thanks and regards,
Bruce

Message was edited by: bruceduong


#9

Bruceduong,

I have downloaded and installed version 6.4 beta and that looks like it has resolved the issue with the code editor in the Oracle instance we were having issues with. The code editor opened very quickly this time with in version 6.4.

Thank you for the help.


#10

Thank you very much rebelf for your note.

This is great news :-). Roman did a good job with the changes.

There are some changes for other issues we would like to include in the next build. If everything goes as planned, we will release the first 6.4 Beta build early next week. We will provide the list of bug fixes in the build upto date for you and all our Community users.

Much appreciated if you could use 6.4 Beta build, and provide feedback on issues, bugs. v6.4 GA should be available early Oct.

Many thanks again for your feedback.

Regards,
Bruce