Toad World® Forums

SQL Recall annoying change


When I click on SQL Recall and search for text, it now shows the named SQL, not the history (which it has displayed for years). 99.9% of the time, I am interested in the history (and I would think most people are). Please change this back, at least as an option.

Thanks. Paul



I assume you’re using the “SQL Contains” box to filter entries? If so, I’m seeing this filter apply to all 3 SQL Recall tabs. Please tell me what I’m missing.



That might be true, but in all previous versions, the tab displayed was the history, not named sql. Since I use the history incredibly often (sometimes dozens of times in a day), it is an annoyance to have to switch tabs every time. Basically, I would just like it to default to the history rather than named sql when opened.

Thanks. Paul


Have you tried F8?


Personally I use the Named SQL tab more frequently than the History tab in
SQL Recall. I don’t think that TOAD defaulted to either one in the previous
versions. I think it was remembering your last usage because I often opened
it and was in the Named SQL tab but not always.


It depends on how you open it. F8 is the shortcut to open the SQL recall history. If you want to open to the named SQL tab, you can go to Options -> Toolbars/Menus -> shortcuts and assign a shortcut. Look for Command = named in shortcut options.


Yes, but when I re-start TOAD and click on SQL Recall, it’s back in the Named tab.

Thanks. Paul


I see what you’re talking about now. Thanks


I’m going to guess at what you’re missing, because I missed it at first
too: in Toad 10, when I first opened SQL Recall, the Named SQL tab was
selected. And I didn’t notice those tabs at all, because I always use
History and never switch from one to the other; so I just figured my
history had disappeared and I couldn’t recall it. Only after your
message below did I look closer, see the History/Personal/Named tabs,
and switch to History - which made things much better.

With one exception (bug report follows): I have SQL Recall not pinned,
and attached to the left side of my window. (Output is also over there,
in case that’s significant.) So I hover over SQL Recall on the left
margin, and the SQL Recall window moves out from the margin; I go to SQL
Contains, and click the down-arrow to get to things I’ve searched for
before, and all is still well; but as soon as my cursor moves into the
drop-down list, the SQL Recall window disappears back into the margin!

My workarounds are to click the dropdown and then, without moving the
mouse, up-arrow and down-arrow through the list; or pin the window, do
my business, and unpin it.

Nate Schroeder
IT Commercial Technical Services - Data Management Team
Monsanto Company
800 N. Lindbergh Blvd. G3WI - Saint Louis, MO - 63167