Toad World® Forums

SQL Recall Not capturing all Queries


#1

Hello all,

I am hoping one of you has run into this before. I am running TDA 3.2.0.736. I had a need to go back and look at a query I ran a week ago. I went to SQL Recall to review my queries. However the query in question was not there. I looked around and found that a few of the queries I ran are not appearing in the SQL Recall window. Is there a setting I am not aware of the tells the system to only record certain queries?

Thanks,
Jeff


#2

There is a limit as to how many SQL are retained. This is an option. If you feel this is not the case, then what window was the SQL exectued from.

Debbie


#3

I am running the SQL from the Editor window. And the SQL was only the last few days. And my SQL Recall option is set to 99999999. It is strange it will have one query then skip 4 or 5 then will have the next set of queries and then skip a few and then pick up again.


#4

I also ran into this. When you highlight a segment of code and execute it, then SQL recall doesn’t capture it. When you place the cursor at the section of code and execute current SQL it does capture it. Might be the same issue you are seeing.


#5

When you execute a script the whole content is saved. Is it possible that the sql you are looking for in lower down in the saved SQL. When you look at SQL Recall we show preview of first SQL. Hold the mouse over each row and you will see the whole script in the hint.

Debbie


#6

This works for me in the current code base.

Debbie


#7

I recently got a license Toad for Oracle Xpert v 11.6.1.6. I ran an sql query this morning and I am not seeing the query as the last executed query. The last executed query is showing a query ran yesterday. Any ideas why the last executed query is not showing today’s executed query?


#8

This is Toad Data Point forum.

You need Toad for Oracle forum http://toadfororacle.com/forumindex.jspa?categoryID=649