Toad World® Forums

Suppress schema name showing in procedure/package/function source tab

This is probably a dumb question and there’s something really obvious that I’m missing, but I’d like to know how I can switch off the schema name from showing in the package/proc/function source tabs in v11, eg:

CREATE OR REPLACE FUNCTION SCHEMA_NAME.function_name…

I want that to display as:

CREATE OR REPLACE FUNCTION function_name…

For the life of me, I cannot work out how to stop it from being appended - can’t see anything in the View > Options (I’ve searched!) or any option on the rhs of the schema browser. I’m sure there’s a way to do it, because I’m pretty sure I had it set up this way in v10.6, but I just can’t find it!

Help?!

It follows the editor settings.

Options -> Editor -> open/save -> owner name

Aha, thanks!

Unfortunately, changing that option to not include the schema name made Toad freeze *{:frowning: (I’m running the latest beta, if that helps; 11.1.0.13)

1 restart later and it looks fine. Hurrah! \o/

I just tried changing that setting here and didn’t get a freeze. If you
can reproduce it, please let me know exactly what the steps are to do that.
Thanks.

-John

I have TOAD 11

I tried it didn’t freeze