Toad World® Forums

System.Exception Tried initializing facilities before licensing was setup

Just downloaded TDA 3.1.0.638 - to upgrade from 3.0.1.1734. Did a typical install which seems to run without incident. When I try to start TDA, am getting a “System.Exception Tried initializing facilities before licensing was setup.”

On starting, the license panel opens. It shows both a 30 day trial and an our permanent license info (from Toad for Oracle xpert) This is on a newer Window 7 box.

Details of error:
System.Exception
Tried initializing facilities before licensing was setup
Stack Trace:
at Quest.Toad.Util.FacilityFactory.CheckInit()
at Quest.Toad.Util.FacilityFactory.GetFacilities(String facilityPath)
at Quest.Toad.Db.Provider.GetProviders()
at Quest.Toad.ConnectionManager.ConnectionHierarchy.RootNodeInitialization(ConnGroupNode node)
at Quest.Toad.ConnectionManager.ConnectionHierarchy…ctor()
at Quest.Toad.ConnectionManager.ConnectionHierarchy.get_Instance()
at Quest.Toad.StartupForm.LoadAssemblies()

Any one else getting this? Solution?

Thanks.
jh

Just a quick update.

I uninstalled the base version and then installed the pro version. After the install the pro version started fine but only has the trial license. So the base version recognizes the legacy license but pops the error and closes when starting while the pro version won’t recognize the legacy license but start fine on a 30 day trial.

Maybe I’m going to have to log this one with support…

jh

The Pro version will not honor the Toad for Oracle key. The issue seems to have something to do with this key. To work on debugging this I need someone with this issue to email me privately with thier Toad for Oracle key. I also need to have a few extra files.

Can you help me to work on this issue? dpeabody@quest.com

Debbie

Debbie,

Thanks for the info. As far as I know we’re paid up for support. Am I correct in thinking I should put in a support request and we’ll pick it up there?

jh

I have confirmed that the issue is caused by using an old Toad for Oracle key. Go ahead and open support case. I have informed support of this issue and we will see what is the best way to handle.

Debbie

Just a quick update - our legacy keys simply didn’t work with the upgraded version and support provided us updated license information. If you hit this problem, you problably will need to contact support.

jh

Yes. You are correct. We have found the bug and fixed this issue in our TDA 3.2 code.

Debbie