Toad World® Forums

Task scheduler does not work


#1

Hi there,
I have problem with the function in subject, so I have scheduled a job time ago and it worked normally, then since about a month not anymore.

Is there anyone who che let me know exactly which are the step to follow to schedule it again and run normally


#2

Hi Savino,

I would go into the Task Scheduler under Utilities -> Task Scheduler. Double-click on your task to edit it. Then, go to the “Triggers” tab, select the desired trigger and click the “Edit” button. That should allow you to change how the task is triggered.

Let us know if you continue to have any problems.

-John


#3

Hi there,
thank you for you help, but this is the way how I create the task the problem is that then it does not work/run it in automatic and if I run it manually from atsk scheduler it is the same, so I guess something I do i wrong but I don’t understant what.

Help Help Help and of course thanks in advance for it


#4

Hi Savino,

Can you provide some step-by-step detail about what kind of task you’re trying to set up and how you’re doing it? I just tried creating a basic tasks using Toad 13.0. I’ll outline my steps here in case it helps at all:

  1. I opened Task Scheduler
  2. I clicked on the button to create a new task, which launches the wizard
  3. I entered a name for the task and clicked Next
  4. On the actions page, I clicked “New”, chose “Display a message” (for my test) and entered a title and message. Then clicked “OK” and “Next”.
  5. On the triggers page, I clicked “New”, left the option as “On a schedule”, chose “One Time” and set a time. I also made sure “Enabled” was selected and clicked “OK” and “Next”.
  6. I then clicked “Next” again at the login page and entered my user credentials.
  7. I then clicked “OK” to finish.

At the specified time, a dialog popped up as expected and showed me my message. This is just a very basic test, but it follows the basic process. Are you performing different steps when you create your task?

-John


#5

Hi there,
I have tried to follow your tasks, thank you! but when I try to use display message and then OK-NEXT I get the error message this action has been deprecated.

In any case the SQL script worked before without any problem

Mah


#6

Hi Savino,

Yes, the “Display a Message” and “Send an e-mail” task actions were deprecated by Microsoft in Windows 8 and higher. I was merely using that as an example. You can still create a “Start a program” task if you’d like to do a test. Simply replace step 4 above with “Start a program” and pick something simple like “Toad.exe” or “Notepad.exe”. Then, continue with step 5 above.

-John


#7

Hi John,
tried with notepad and it works, then I tried again using SQL script (abd.sql) instead of notepad.exe and does not start, putting on LAST RUN RESULT “operation cancelled by the operator”.
Is is something with file format (.sql)?
I really don’t understand

THANK YOU VERY MUCH!!!
Sav.


#8

Hi Savino,

If you’re only entering the script file name as the target of the “Start a program” action, it will most likely only attempt to open the script using the default application. If no default application is defined, or if the process running the task doesn’t have access to that application, Windows could easily display that response.

What are you trying to do with that script file? Are you trying to execute it at pre-scheduled times? If so, I would create a new “Execute Script” task in the Automation Designer and schedule it, as in the following:

  1. Open Toad and log into the database you want to execute the script against
  2. Open the Automation Designer
  3. Go to the DB Misc tab and add an “Execute Script” action.
  4. Double-click on the action to edit its properties and add the script file in question. Select your output options.
  5. Click “Apply” and then close the properties window
  6. Right-click on the “Execute Script” action you just created and select “Schedule…”.
  7. Toad will automatically add the correct action to the Task Scheduler wizard, so you can simply click next and select your triggers when the action should be run.

-John


#9

Hi John,
IT WORKS!!!

THANK YOU REALLY MUCH!!!

Anyway could be good to understand why before was working just using the Schedule action and now following this process, but good the object is reached!!!