Schedule Automation Designer App/Actions does not start


I have an app that I tested successfully. It is an export to text file with option SQL text that displays SYSDATE from dual. I tried to schedule this job, answered all the dialog boxes and it is on the schedule queue. The time came and went and nothing that I can see occurred. The output of the App creates a text file, but the date of the files has not changed.

So, is there something I need to turn on in order to use the scheduler. An example would help, but to me it looked straight forward.



Look for your task in windows task scheduler to see if it ran.

You can also grab the command that Toad runs out of there to see what happens if you run it from command line. You can also test it that way to take scheduler out of the equation.

Thanks John,

I found the message under Windows Task Scheduler. Login failure. I am not administrator on my desktop. Is that the issue? I assume login failure is my windows network login/password.

Maybe, I'm not sure.

Does it help if you set the schedule to "Run only when user is logged on"?

Hi John,

I tried to "Run only when user is logged on" and same issue.

I put a ticket into our IT help desk to get resolution. I'll keep you posted.


The issue with not scheduling in auto designer is my computer wasn't set up for batch jobs. Once this was set I was able to schedule from auto designer. Thanks for your help.


1 Like

After IT help desk set my privileges run batch job via windows task scheduler, the scheduled job on task scheduler ran successfully. The status was still running, so I checked Toad for Oracle application and I received two "Stack Overflow" messages. When I clicked OK on both message windows, task scheduler completed (stopped running). Any suggestions would be appreciated. Thanks.


Here are the messages:



Are these steps to reproduce it right? If not, please correct them.

  1. Toad not running, an export dataset action is scheduled.
  2. scheduled time passes
  3. Manually start Toad and go to automation designer
  4. scheduled action status is "running"
  5. double-click the action -> error.

Steps to reproduce

  1. Toad is open and running and export dataset action is schedule
  2. Updated Schedule job to change time a few minutes ahead of current time
  3. Toad is already running
  4. Schedule job executed and see that the status is "running"
  5. Didn't double-click the action error

clicked OK on both messages
windows task schedule status updated from running to completed

The actions in the schedule job is a file iterator with one date row.
Then an export action to save results to output file with the Option using SQL text to Select date (with iteration parameter) from dual;

Update - The schedule job works fine when Toad is not open. Get the error when open.


Thanks for the update. I got a little distracted this morning and haven't tested this yet but I will.