Toad World® Forums

TDA automation encoding problem

Automation does not pay attention to encoding. So all i see is a bunch of question marks in my result set exported to excel sheet. However i have never encountered with the problem in editor. All works fine. My NLS_LANG is RUSSIA.CIS_CL8MSWIN1251. Hope there’s a chance to solve a problem and not to use decode or something in my queries.

Interesting problem. Can you right clcik on the editor and send me a screen shot showing the Character encoding? It is a sub menu down near the bottom on the right click of the editor.

Also, once connected to Oracle, go to the Tools | Administrator | Session Info. Go to the NLS Parameters tab and take a full screenshot. This tells me the NLS Parms for client, server, and session.

Thirdly, can you attach a sample excel file? We have a whole team in Russia that uses TDA and does not have issues, so perhaps we can find a work around.

Debbie

Can you please try and make sure that “direct” export without Automation works fine?

Thanks,

Igor.

The character encoding in editor is "cyrillic (Windows)". Result set outputs properly in editor as you can see on screenshot. Also I attach screenshot of nls_parameters and excel file taken from the automation process.

The character encoding in editor is “cyrillic (Windows)”. Result set outputs properly in editor as you can see on screenshot. Also I attach screenshot of nls_parameters and excel file taken from the automation process.
sample_file.xls (11 KB)

The character encoding in editor is "cyrillic (Windows)". Result set outputs properly in editor as you can see on screenshot. Also I attach screenshot of nls_parameters and excel file taken from the automation process.

I entered CR89780 on this issue. Let me investigate and see if there is a work around.

Debbie

Thanks for your help. One thing I forgot to add, NLS_LANG in Oracle DB taken from the V$NLS_PARAMETERS VIEW is RUSSIAN_CIS.AL16UTF16. In Tools --> Session tab it’s AMERICAN_AMERICA.AL16UTF16.

Message was edited by: bobrovskyaa_718

I noticed that I can reproduce the issue if I use a SQL file that is not saved as a unicode text file. If I save the file as a unicode file, automatio works correctly.

Can you check to see that the *.sql file is saved as unicode? If you copy and paste the SQL into a new editor and save from with in TDA, it will ask you if you want to save it as unicode.

Debbie

Yes, SQL file must be save in Unicode. Thank you very much for solution.
It will be nice if TDA converted SQL in Unicode automatically on Add to Project.

It will be nice if TDA converted SQL in Unicode automatically on Add to Project.
Toad asks about changing encoding on savng sql from Editor. See attached.

In your case - you have to convert all your files with any text tool that supports such conversions or by re-saving each sql file in TDA.

good luck!
saveUnicode.png

Toad asks about changing encoding on savng sql from Editor. See attached.
Toad asks if you write sql in editor. I’ve just opened sql files and had not this warning from toad.

But how it reacts when you save the file?
I suppose you have to place at least empty space to enable saving action though.

I open some sql files and then add to project them. That’s all. All I have to do is to pick up them in automation.

Right, but as I see for now you have some issues with it. So you have to apply a workaround (re-save with unicode) to work it out.