Toad World® Forums

TDA One-click Export to Linked Excel Problem

Hello, I am receiving the following error message whenever I want to export a result-set to a linked excel instance. I am using Windows 7 64-bit, Excel 32-bit, and TDA 32-bit 3.0.1.1734. Any ideas?

4:33:44 PM Thread (18) Export Started [3/15/2012 4:33:44 PM]
4:33:44 PM Thread (18) Export using connection: XXXX
4:33:44 PM Thread (18) Export using connection: XXXX
4:33:44 PM Thread (18) Export Wizard: Building object list
4:33:44 PM Thread (18) Exporting Data (1 of 1)
4:33:44 PM Thread (18) Object SQL Query started.
4:33:47 PM Thread (18) User cancelled
4:33:47 PM Thread (19) DoneReadTreadWriter
4:33:47 PM Thread (19) DoneReadThreadWriter finally - adapter null
4:33:47 PM Thread (18) Object SQL Query finished with error: Call was rejected by callee. (Exception from HRESULT: 0x80010001 (RPC_E_CALL_REJECTED))
4:33:47 PM Thread (18) at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at System.Type.InvokeMember(String name, BindingFlags invokeAttr, Binder binder, Object target, Object[] args, CultureInfo culture)
at Quest.Toad.ImportExport.Writers.WriterExcelInstance.TryCultureGetProperty(Type type, String property, Object target, Object[] args)
at Quest.Toad.ImportExport.Writers.WriterExcelInstance.WriteHeaderInternalQuery()
at Quest.Toad.ImportExport.Writers.WriterExcelInstance.WriteHeader(Object tableObject)
at Quest.Toad.ImportExport.ExportObjectData.adapter_SchemaReady(Object sender, FastTableArgs args)
4:37:01 PM Thread (18) Export Finished [3/15/2012 4:37:01 PM]

Message was edited by: Specialk9984

This is a very generic Ms Office issue. Were you able to create a linked query without using TDA? Does it happen recently or all the time, did you try reboot your system?

This error reoccurs after reboot. The linked Excel instance does get created (I am able to use it after clicking through and closing the error messages).

I am using 32-bit Microsoft Excel 2007 - which is supported by TDA.

Is the error message helpful at all, or is it too generic to identify what is causing the error?

What kind of database are you connected to? The message is from Excel and is too generic to work with.

Look in the help file of Excel and see if you can create a link query manually.

I tested linked query here using Oracle conneciton with OCI instant client and it worked fine.

Debbie

I’m connecting to MySQL 5.1… I can create linked queries via Excel but that defeats the purpose of the quick export.

I would go to ODBC manager of OS and turn on logging. Try again and look in the log. This usually gives you more details of why the call is rejected.

I just tried one-click export to linked Query using mySQL and it worked fine. The first time I did it I had to choose the MySQL ODBC driver and I also had to tell Excel it was OKay to use linked queries and add a password. After that it was fine. Perhaps you have a setting in Excel that is rejecting this from being made programatically???

Debbie

Well… ok this is odd.

I just exported an excel linked query today with no errors. (I had probably previous approved security settings in excel long before this error cropped up)

I have no idea what the deal is, and I have not applied any additional excel updates that I am aware of. (running excel 07 sp3)

Thanks for looking at this Debbie, if it comes back I will turn on ODBC logging and re-post here with more information.

Mnnnn…self healing software. I like that. Let me know if it crops up again.
Debbie