Toad World® Forums

TDM connection error , even with TCP/IP

Hi,

I have been using TOAD for ORACLE to connect to the Oracle server.
Yesterday, I downloaded the trial version of the TDM3.

I am using ‘Connections’ under File to connect to database. On selecting the ‘Native Client Connection method or TCP/IP’ , I can see the Service Name in the dropdown lists.
I am trying to connect to the same database but am running into errors like ‘Invalid SID’ while using TCP/IP or ‘Could not resolve connection identifier’ while using native client connection.
Even if I manually type the values for all the fields, and not use the dropdown values, I get the same error.

I have read couple of threads of this and other forums. Based on the suggestions mentioned there, here are the steps I tried, in that order:

  1. Added ORACLE_HOME environment (user)variable with the value C:\ORACLE\OraXE\app\oracle\product\10.2.0\server\NETWORK\ADMIN.

  2. Added TNS_ADMIN environment (user)variable with the value: C:\ORACLE\OraXE\app\oracle\product\10.2.0\server\NETWORK\ADMIN

  3. Copied TNSNAMES.ORA to C:\Program Files (x86)\Quest Software\Toad Data Modeler 3\Bin

  4. Copied OCI.DLL to C:\Program Files (x86)\Quest Software\Toad Data Modeler 3\Bin

  5. Added TNS_ADMIN environment (system) variable.

I restarted TDM, after every change.

I have a Windows 7 system and could not find HKEY_LOCAL_MACHINE/SOFTWARE/ORACLE.
I also could not edit the SQLNET.ORA file to add NAMES.DIRECTORY_PATH.

database RE: Oracle 10g.

Please advice.
Thanks for all the help.
Prarthana

Just realized… I downloaded the freeware version, not the trial version, as mentioned above.
Sorry about the typo.

Hi,

what happens when you try to use RE Wizard instead of the Connections dialog? Are you able to establish a connection to your database via the wizard? Please make sure you work with correct version of Oracle (for Oracle 10g you must select Oracle 10 item from the list of databases etc. If you choose Oracle 11 or Oracle 9 then you may get errors.)

Also, please make sure there is no problem with firewall and your port number is correct. Thank you.

Vaclav & TDM team

The database selected is Oracle 10g.

On using the wizard, with TCP/IP connection, I get ‘Connection failed because of the following error: NET:Invalid SID’

I am on the local network, connected through LAN Cable.
I can connect to the database using TOAD for Oracle, with same connection values.

Changing part of the SID, allowed me to connect to the database, using the RE Wizard.

Hi, what did you change to get it to work. I have a similar problem. Thanks