Toad World® Forums

TDP 4.1 Import Wizard Issue

It seems that Importing data from MySQL to Oracle is not working. I tried to import the data from MySQL to Local Storage to Oracle, same issue. The Import Wizards runs without any errors. However, import from MySQL to Access works fine. Any thoughts?

Do the import again. In the summary window there is a link to the log file. Can you get this and post?

Sorry for the late response, but here it is:

11:14:03 AM Thread (1) Connecting to :ORACLE_ST.
11:14:03 AM Thread (20) Import Started [1/16/2017 11:14:03 AM]
11:14:03 AM Thread (20) Processing “Embedded Query” into “ORACLE_ST.GAMEMAIL”
11:14:04 AM Thread (20) Heterogeneous Import 1/16/2017 11:14:04 AM
11:14:04 AM Thread (20) Importing 1 out of 1 files
11:14:04 AM Thread (20) Import embedded query
11:14:04 AM Thread (20) Import block size optimization is enabled
11:14:04 AM Thread (20) Change Schema to ORACLE_ST
11:14:04 AM Thread (20) Inserting row 2000 into table GAMEMAIL
11:14:04 AM Thread (20) Inserting row 6000 into table GAMEMAIL
11:14:05 AM Thread (20) Inserting row 14000 into table GAMEMAIL
11:14:07 AM Thread (20) Inserting row 30000 into table GAMEMAIL
11:14:10 AM Thread (20) Inserting row 50000 into table GAMEMAIL
11:14:13 AM Thread (20) Inserting row 70000 into table GAMEMAIL
11:14:16 AM Thread (20) Inserting row 90000 into table GAMEMAIL
11:14:18 AM Thread (20) Inserting row 110000 into table GAMEMAIL
11:14:21 AM Thread (20) Inserting row 130000 into table GAMEMAIL
11:14:23 AM Thread (20) Inserting row 150000 into table GAMEMAIL
11:14:26 AM Thread (20) Inserting row 170000 into table GAMEMAIL
11:14:29 AM Thread (20) Inserting row 190000 into table GAMEMAIL
11:14:32 AM Thread (20) Inserting row 210000 into table GAMEMAIL
11:14:36 AM Thread (20) Inserting row 230000 into table GAMEMAIL
11:14:39 AM Thread (20) Inserting row 250000 into table GAMEMAIL
11:14:42 AM Thread (20) Inserting row 270000 into table GAMEMAIL
11:14:43 AM Thread (20) Inserting row 284397 into table GAMEMAIL
11:14:43 AM Thread (20) 284397 rows were processed.
11:14:43 AM Thread (20) A total of 0 out of 284397 rows were imported to table GAMEMAIL.

11:14:43 AM Thread (20) Import Finished [1/16/2017 11:14:43 AM]
11:14:43 AM Thread (20) Import time: 00:00:39.9530386

After research further, It seems that this is the import is not working because of CLOB datatype in the table.

That is true. We do not support importing into clobs. When going through the import wizard it would show that the clob column would be excluded.

From the logging lines you posted the import looks successful

Thank you for the clarification.

The automation job was running the import wizard and the records were inserted into the table, including the CLOB field until recently. It stopped working late last year when I upgraded from 3.8 to 4.01 to 4.1

Although the log file does not produce any errors, no records are inserted into the table.

Can you open a support ticket? I want to get this handled for you. Please provide for the support person the full import file.

I submitted the support ticket (#3872761).

Yes, I got the support subcase. That was very helpful. I was able to easily reproduce the issue and have scheduled QAT-9800 to be worked on in the next sprint. I will try to get the fix in an upcoming Beta

Thank you Debbie. Unfortunately, this has become a major issue and now we need to update our automation scripts and replace the Import activity with a Loop/Insert activity.

Sorry to hear of the inconvenience. I will still let you know when available in a Beta.