Toad 10 ( error

One of my developers got a strange pop-up error when using PL/SQL editor:

Toad Message
Path to RMAN not valid.
See executables page in Options.

Sequence of events:

  1. start Toad
  2. login to Oracle
  3. open Editor
  4. Use file open to load car_file.bdy from network drive
    (.bdy loads into error without error)
  5. hit green arrow
  6. get message about RMAN

I tried editing the same file on my workstation, but after I used the file open to load the car_file.bdy from the network drive - it immediately indicated a error: ERROR line 790, col 8, ending_line 790, ending_col 11, Found ‘loop’, Expecting: IF

It seems like the error did not trigger the same actions in the developers Toad that mine did.

I will try a full uninstall / re-install, but thought I would check here first to see if anyone else has come across this.

ian jackson

Couple of things – the editor now supports RMAN language – are you
working on backup scripts? The execute depends on the file type, so backup tries
to run RMAN. So open toad options and see if you have the rman executable path

  1. no … the code does not contain backup scripts … it is a straight forward package body.
  2. we do not enable RMAN for developers … only DBA’s
  3. the same package body in my Toad 10 just produced a simple error … nothing about RMAN.

ian jackson


  1. R-click in Editor and choose “Configure Editor tab styles”

  2. Change the necessary values in the Desktop columns so that it matches the

that was it … thank you very much.

all of them except text was wrong.


t he icon on tab in the editor (looks like an open cardboard box for a body and
a closed cardboard box for a spec) … it that normal? I guess I was expecting a
pl/sql graphic … like when you go new tab: pl/sql.



Ian, I’m not sure if you missed my post or not, please see my previous post. This is a known issue for some upgrading users and easy to fix

yes, I got it … just the toadgroups time warp at work.

thanks Brad


Right – works for you – but what if the other guy has option set to
default to rman style toad editor tabs or simply set it by accident on that file
– then he’s going to see cannot find rman – what he needs to
make sure is that he tells toad that default tabs in editor are pl/sql or sql
and make sure it’s not set to something else for that package/file as
well. In other words I think the user has a local setting casuing this

Yes, what you are seeing is normal