Toad 10 with Oracle 19c Client


I am using toad 10 and Oracle 19 c client , but toad is not picking up the instant client I installed and is giving error No Oracle Clients installed

Information :

  1. ORACLE_HOME= C:\app\orahome19c\product\19.0.0\client_1 is set in ENV Variables and added to Path variable =%ORACLE_HOME\bin%
  2. Tnsnames.ora and sqlnet.ora have been in folder C:\Oracle\network\admin

Please let me know the resolution how to resolve this. I was trying to upload the call stack as well but it seems portal doesn't allow new users to upload attachments.

If you have 32 bit Toad, you need a 32 bit Oracle client.
If you have 64 bit Toad, you need a 64 bit Oracle client.

You don't need to add an ORACLE_HOME environment variable. If this is a full client, the installer should have added it to your path. Check. If this is an instant client, you don't have a \bin folder and the path would just need whatever folder you unzipped it to.

In either case, you need to reboot after adding something to the system path for Toad to pick it up.

I increased your trust level so you can now post a call stack.

Oracle 19c will support Toad Version 10 ?

I tried without Oracle home with oracle home , with full client , with instant client but it dint work. RIght now , Oracle 19c instant client is installed on my machine. We don't have the zipped folder , we have Software center of our clients portal from which we have installed. I have used 1st option in that - i.e instant client.

Now , please suggest what needs to be done further.
CallStack.txt (9.4 KB)

It looks like you have a 32 bit Toad.

Have you confirmed that you are using a 32 bit Oracle client?

Yes , i am using both 64 bit. Now i tried the same with instant client. Unzipped the instant client folder into C:\instantclient.

Made entry in Path : C:\instantclient and also added TNS_ADMIN and placed tnsnames.ora in C:\instantclient folder. Then also, Toad is not picking up the client and it says " You do not have any oracle clients installed".

Am I missing anything here ?

I don't think you are missing anything. I just tried Toad 10.1 with a 19c instant client and couldn't get Toad to find it either. I guess it's not supported and you should stick with a full client (or older version of an instant client).

I am fairly certain that 64 bit Toad was not released until version 11.5. Which means you have 32 bit Toad, and you need to be using a 32 bit client.

Since Toad 10.1 is 14 years old, your best bet would be with a client that is around the same age. Oracle client 10.2 is a little newer but that should work well.

Edit: I had to run Toad 10.1 as Administrator to get it to work with Oracle client 10.2 on Windows 10.