Toad World® Forums

Toad 12.6 Schema Compare isn't working


#1

I have Toad 12.6 with the DB Admin Option. I’m seeing differences when I run the exact same compare on 12.5 and 12.6. 12.5 is working and 12.6 is not. (These same compares also work correctly on 12.1)

I run the Toad Schema Compare between my Customer Accpetance Testing (CAT) environment for 1 schema against my Quality Assurance (QA) database for the same schema.

If I run with Toad 12.6 the following are not showing as differences between CAT and QA

  • Foreign key constraint on 1 table in CAT is not showing as a difference because it is missing on the table in QA
  • New package & package body on QA are not showing as differences in CAT which doesn’t have the changes yet.
  • New indexes on QA are not showing as differences in CAT.

#2

Are you sure that you have the same schema compare options checked in 12.6 as you did in 12.5?

Can you send me a script to create the objects in question so I can reproduce the problem? You can send it to me directly if you want - john.dorlon@quest.com