TOAD 13.1 error "Could not load the Microsoft Access Database Engine ..."

it does say the installer is not compatible with Office installed with windows installer -- I just want to try to be certain I do not dig a deeper hole --

I saw that too. Clear as mud.

Ok, I have a Windows 10 VM with MS Office 365 64 bit.
I ran the MS 365 Access Runtime installer (it took about 5-10 minutes)
Now when I start Access, it's just the runtime and I no longer have the full Access. :frowning:

Luckily I made a snapshot of the VM first.
So I rolled back....but like you, I can't export from Toad to Access with the full version of Access 365.

I'll try some of those older runtimes. I'll edit this post with the results.

EDIT: With MS Office 365, 64 bit already installed...

  • Installing Microsoft 365 Access Runtime downgrades your MS Access. Don't do it.
  • The installer for MS Access 2016 told me that it would not install because I already had a "click to run MS Office installed"
  • The installer for MS Access 2013 installed successfully. After that, both MS Access products were installed. Exporting from 64 bit Toad worked successfully. The only "gotcha" is that after installation, .accdb files were associated with the runtime, so I had to right-click one and choose "open with" and set it to the Access 365. After that, all seems well. Click here for the MS Access 2013 runtime.

I'll add it to my to-do list to see if I can get Toad to work with the full MS Access instead of only runtime. This is kinda ridiculous.

Thank you John.. You just saved me from digging that deeper hole -- Did you check to see if you could export using the runtime only?

Well, that's what I did yesterday and it worked, so I didn't re-test it just now.

Thank you -- I did not put yesterday's test together -- Still cannot operate with runtime only, was just curious --

Thank you John -- I will install and report back -

John, Export works greatly now !! Thank you so much -- -- Following installation from supplied link, Export works as expected; planting Access Database files without argument, without further user input --
Have a great day -

1 Like