TOAD 13.1 error "Could not load the Microsoft Access Database Engine ..."

It looks like there is an incompatibility between TOAD and Microsoft Access: You get an error anytime you try to export the results to an access database (accdb). It does not matter if you have the right version of Access or not! The problem is that - for 32-bits TOAD - you need to export the results into an “mdb” extension database. If you use “accdb” you get the error.


Please don’t write sentences in all caps here. I don’t know how you meant it, but It comes off as “yelling”. Nobody likes to be yelled at.

I just exported “select * from scott.EMP” in Toad, 32 bit, to an .accdb file without any errors.

The MS Access driver version could be the cause of the problem. The latest version is here:

In addition to using the proper Access driver, as Mr. Dorlon mentioned, also make sure that the bitness of your Microsoft Database Access Engine matches the bitness of your Toad executable. See the following Knowledge Base Article on Quest’s Support site for more information:

I already checked the bitness of the TOAD versus Microsoft Access: I have the same 32-bits. Access works fine. If I change the extension to “mdb” then TOAD saves the data. If I use the “accdb” then it fails. Running TOAD on Windows 10 machines.


Sami El-Murr

Yeah, it wouldn’t work at all if the bits didn’t match. I believe installing the driver that I mentioned above will fix your problem, even if you already have the full version of MS Access already installed.

What version of Access do you have?


I have the 32-bits version


Sami El-Murr

Control System Engineering

ICS Cybersecurity Expert


I have nearly the same version installed (mine is 16.0.11029.20045, 32 bit).

In Control Panel -> Programs and Features, I also have this, which is what Toad actually uses when writing the file.

The 2016 version that I mentioned before should work too (otherwise I would not have kept the link for it!), but the 2010 version is here:

I don't know if I should post here, or start a new topic. I am receiving the same error. I have Toad for Oracle 13.1 64 bit, and MS Office 2016 64 bit. Fresh installs of both. I have two Oracle installations, 12.2 64 bit, and 11.? 32 bit which I require for SAP Business Object IDT. I don't know where to look or what to look for to see how the products connect together to be able to export the data to any form of an access database.

Toad 11.x does not connect/communicate with Toad 13.1 at all. Which version of Toad are you having problems with?

Sounds like you should keep your export to Access in the 13.1 version of Toad.

Sorry, 11.x was referring to a 32bit Oracle installation like 11g, not Toad. I need my Toad 13.1 64bit to talk to my Access 2016 64bit.


John, I have been using Schema Browser> Tables. Select table(s) Data export as Access Database Files. I have an empty directory mapped that has always accepted these files. An external user later opens these Access Database files with 'R' for use in reports.

We had been using ACCESS 13 for years with no issues with TOAD up to 13.last... Since last report time, I have moved to TOAD for Oracle 14.. -- and we moved to Office 365 which changed all Office applications to 64-bit.

Now I am getting a message from Toad stating: "Could not load the Microsoft Access Database Engine. This is not the full MS ACCESS product, just the runtime engine. The 64 bit version is required for this version of TOAD."I tried with the old 32 but installation of TOAD and got the same message, except that it stated that the 32 but version is required for this version of TOAD -- which is 32 bit -- That is why I thought moving to 64 bit toad would work -- but it did not.

John -- should the same MS drive mentioned above help now, or will I just be looking for a later driver ? -- Thank you!

Hi John,

The latest version that I am aware of is here: You'll definitely want the 64 bit version of it with 64 bit Toad.

I tried to install the 64 bit version of it on my PC to test it before posting this, but I have 32 bit MS Office installed, and they won't install together.

Edit: after a quick search, I also found this
Note: This works with Toad 13.3 64 bit and 14.0 64 bit, but only install this if you don't have the full MS Access already installed. If you do, it will downgrade your Access installation to the runtime.


I will give it a go -- Thank you.

I found a Win 10 machine with no office installed. Trying the new one now. Will post the results as soon as I know something.

The new one works with both Toad 13.3 64 bit and 14.0 64 bit.

1 Like

The pc executing the export has OFFICE 365 - installed by a push -
Would you expect this MS fix to have any effect on a machine that has the Office 365 installed?

I wouldn't expect any problems from that. I've had earlier versions of the runtime installed with MS Office on the same PC, without problems. Haven't tried it with this version though.

Runtime engine is discussed on the last URL -- will work through that

It says "MS 365 Access Runtime".

I've got MS Office 2016 installed on a VM. I can try installing this on top and see what happens. I think it'll be fine though.