Toad World® Forums

Toad 13 Cannot Move toolbars


#1

Hi!

I upgraded to T13 last week. I’ve noticed that I can’t move the toolbars around like I used to. Was this intentional? If so, why?

Thanks,

Mike


#2

They were so easy to accidentally move, so we locked them by default. To unlock, just right-click and uncheck “Lock toolbars”


#3

Excellent! Thank you!


#4

My problem seems to go beyond the above. If I right-click on any of the toolbars and try to select "Lock toolbars" so that it unchecks, nothing happens. In fact, none of the options work on that right-click menu. The only way I can customize is to extend the "Add or Remove Buttons" arrow from the toolbar arrows. But, even with that I cannot move any of the toolbars. I've checked the options and I don't see another place to unlock the toolbars... help?


#5

After you right-click and uncheck "lock toolbars", can you drag your toolbars around from the grips shown where I circled in red?

image


#6

No, sorry, I wasn't quite clear. Lock toolbars will not uncheck. Nothing from that menu will uncheck. It's as if that entire menu is locked as I cannot select anything from it. I've also relaunched Toad incase something just needed reset. This is after a recent upgrade pushed by our desktop support folks, so I'm wondering if something got corrupted with the upgrade.


#7

Oh, I see.

Try this:

  1. Go to Options -> General.
  2. Click the 'Open Folder' button next to the box for Application Data Directory. An explorer window will open.
  3. Shut down Toad.
  4. In the Explorer window, go down into the User Files folder.
  5. rename Toolbars.ini and Toolbars_Default.ini. (Toad will create new files when it runs again)
  6. Restart Toad and see if that fixed it.

#8

Hi,
Unfortunately, no. Nothing on that right-click menu is clickable. I have this same problem with not only the main toolbars, but the toolbars from the other modules. For instance, with an Editor window open, I cannot unlock those toolbars either.
Ideas?
Thanks, Brian


#9

probably a reset of all options will do it. See this post for directions on how to do that, and a few posts down for posts about how to pull back your connections and a few other settings.


#10

Actually I at least found a workaround. I was looking in the Toad.ini and found this:
Lock main toolbar=1
I changed it to this:
Lock main toolbar=0
Now, the right-click menu still doesn't let me click anything, but the toolbars are unlocked and I can move them around. I know enough about the User Files that I can recover my connections and passwords (been there, done that, lol). So, for now I'll use the workaround and when I get a chance I will reset the settings.