Toad World® Forums

Problems with Toad 14.0 crashing

Hi

Toad 14.0.75.662

I've been using 14.0 few weeks now, but I have had multiple occasions when Toad just crashes for no good reason. I am not executing any query or anything out of the ordinary (Editor, Schema Browser and Session Browser are the only ones that are opened)

I was suspecting internet access, since Toad is installed in our company intranet and no internet access allowed from there. But I did install Toad with this flag:

PS> C:\Windows\system32\msiexec /i "...\install\Oracle\toad\ToadforOracle_GA_14.0.75.662_x64_En.msi" /q RESTRICTIONS=i

And in regedit, this seems fine:
image

Ofcourse, this might have nothing to do with that internetaccess, I was just wondering.

It is very difficult to reproduce, so I am wondering, if you've noticed anything similar with that version..?

Or do you have some suggestions etc..

Raul

Can you get the call stack, from the error dialog, like this?

Well, that's the thing.
There will not be this box at all:
image

Screen just gets little bit greyed out and it is not responding at all.

For example, the outcome is similar to this:

(ofcourse this example picture is for visual studio, but I didn't take screenshot for Toad, when it happened this morning, so I just found similar picture from the internet)

And I've waited like several minutes before, nothing happens, so I just try to close it and then I get the popup (close the program or wait for the program to respond)

image

Raul

1 Like

Do you ever select text then use the space bar to delete/replace it? That caused this and was fixed recently in beta.

Not that I recall.
But as I tried this out at the moment.
In Editor seems like "ctrl+a" + spacebar works fine.
And by selecting text with mouse from bottom to top + spacebar also fine.

But this seems like it occurs only when selecting text from top to bottom + spacebar (and you must select over 10 line of text). Then Toad crashes each time.

But regarding my problem, I do not recall, that I've done anything similar.
Yes most of the time (if not all), the Editor was indeed opened. I probably have copy/pasted some code to Editor or modified some code etc..

If this issue happens again, is there something that I can do differently for you to investigate this matter further..?

Raul

Just steps to reproduce it, if you can come up with them.

Ok, I'll do my best.

In the mean time, if I would like to try out latest beta and see if this occurs there or not. Could you point me to the right direction, where I can download this..?

Raul

Sorry, I didn't see your message until just now.

The beta is here: Toad for Oracle 15.0 Beta

BTW, the numbering for it is going to change - it's 15.0 right now, but management changed their minds on the next version number. So the next time beta is updated, it will be numbered as 14.1 instead. It will be the same code, just a different number. But you'll have to deinstall 15.0 (if you installed it) and then reinstall 14.1.

And there is a list of the fixes/improvements (so far) in the beta here: Beta Released (15.0.23.720)

Hi

Ok, I think I figured this out.
I tried with Toad 14.0.75.662, since I haven't managed to install latest beta yet.
You may test this with both (14.0 and latest beta, perhaps this has something to do with it, I don't know.

".. ever select text then use the space bar to delete/replace it?"

These are the steps:

  1. Open Editor
  2. Paste oneliner sql statement into the Editor, that doesn't fit to the screen
  3. Open new tab ("Schema Browser" or "Editor", ... etc )
    3.1 You may also open multiple new tabs
  4. Switch back to first tab ("Editor")
  5. Click onto the second tab (or whatever tab you opened in step 3 or 3.1)
  6. Crashes

-- It depends you screen size, for example in my case (1920*1080), this will work for me (note that I have this Navigator also opened, this will take also little space horizontally)
SELECT OWNER, TABLE_NAME, TABLESPACE_NAME, CLUSTER_NAME, IOT_NAME, STATUS, PCT_FREE, PCT_USED, INI_TRANS, MAX_TRANS, INITIAL_EXTENT, NEXT_EXTENT, MIN_EXTENTS, MAX_EXTENTS, PCT_INCREASE, FREELISTS FROM SYS.DBA_TABLES;

-- But this one crashes in my case. I added this column "FREELIST_GROUPS" additionally.
SELECT OWNER, TABLE_NAME, TABLESPACE_NAME, CLUSTER_NAME, IOT_NAME, STATUS, PCT_FREE, PCT_USED, INI_TRANS, MAX_TRANS, INITIAL_EXTENT, NEXT_EXTENT, MIN_EXTENTS, MAX_EXTENTS, PCT_INCREASE, FREELISTS, FREELIST_GROUPS FROM SYS.DBA_TABLES;

To be certain, you may take the whole dba_tables (or what ever view, that has certain amount of columns) columns as well - then you can be certain that this oneliner does not fit to screen.

Regards
Raul

Sounds promising, I'll check it out.

Hi Paul,

Yes! I pasted in a long SQL and it worked fine for me, but then when I turned on the word-wrap option, I easily reproduced this.

So, workaround - disable word wrap. Hopefully we'll have a fix soon.

-John

1 Like

Oh yeah, I have word wrap enabled, didn't notice that at first glance.
By disabling this - it does not crash.

So it was reproducible in latest beta also, yes..?

Raul

Yes, it happens in latest beta also.

The application is unusable in it's current state. Can you advise when a fix will be available? What's the most recent actually production quality build so we can get back to it until Quest resolves this issue?

Matt, does turning off the word wrap option make your Toad not freeze up, or do you have a different problem?

Hi John, thanks for the quick reply. I don't have word wrap enabled at all, and just had the exact same behavior when I select a section of text and hit delete key. I'm on 14.0.75.662, I had the beta earlier and experienced the the issues there too.

Hi Matt,

You said "earlier" - how much earlier did you try the beta? Would you mind trying again with the latest? If you still have a beta installed, and it is version 15.0, you'll have to uninstall and reinstall the latest due to the version number changing - it is now 14.1. You can get the beta here

There was hanging problem with selection of text and space bar, I'm not sure if that applied to delete key as well. This was fixed in beta (at least with spacebar)

If the problem persists in latest beta, let us know, so we can figure out what's causing it and get it fixed.

Thanks.

-John

a couple weeks ago, I have beta 14.1.2.726

Well, there is a later version but I don't think it will solve your problem unless it's due to connection timeouts.

Please follow the steps detailed here to send me your user files folder.

Also some steps to repeat the problem (as best you can if you don't have exact steps). I know you said select and delete text, but is there any more to it?

I'll try to repeat the problem next week. I'll be out the rest of this week due to holidays

Thanks

-John

I'll do that as time permits, but can you tell me the prior stable version (ie. without this defect)?