Toad 17 Installer Disappears on Product Selection

I need to install Toad for oracle for work. I can connect to my SQL databases with other software.

I searched the forums but couldn't find anything related to this issue.

I'm using Windows 10 (64 bit) Enterprise behind an enterprise firewall.

I'm trying to install Toad 17 (64 bit) for Oracle.

Every time I run the installer, "Toad_for_Oracle_2023R2Patch1_x64_Full.exe", the installer will get to the "Product Selection" tab and then totally disappear. I didn't see any obvious errors in Event Viewer. I do not have permissions to my C:\Program Files directory.

Any ideas?

TIA

Hmmm...

It's rare that I see the Toad for Oracle installer just up and disappear, but a few questions for ya...

  • Do you have access to the Oracle Client home folder? This is a requirement for Toad if you'll be connecting Toad to Oracle via the Oracle client. The fact that you don't have access to your C:\Program Files folder just might be a show-stopper here, depending on which install directory location you choose. Toad maintains other files in other places too on the C: drive, so not having read/write access to certain dir locations on the C:\ drive could spell install trouble, unless you get assigned privileges. I'd put my money that this is probably the cause of the issue.

If not, then a few other things come to mind...

  • Are you using 64-bit or 32-bit Oracle client?
    If you intend on using the Oracle client to connect to Oracle, then the Toad installer must match the bitness of the Oracle client... e.g. 64-bit Toad installer needed if you have 64-bit Oracle client, etc. Note that it's possible for some folks to have a 32-bit Oracle client on their 64-bit machine. So a 32-bit Toad installer will be needed in that case.

  • See the Release Notes or User Guide for other Requirements... both docs can be found on the Quest Support site here.

If none of the above help, you may wish to open a Support ticket.

Does the Product Selection page load to show products or does it disappear prior? Have you tried running the installer as Administrator?

Thank you for the prompt response. The window disappears before it shows any products.

I am beginning to think it is a permissions thing. I'm in a constrained enterprise environment where I don't have access to my C:\program files or C:\Program Files(x86).

Does this sound likely?

TIA!

It very well could be a permissions issue. The product selection dialog will check to see which products are available for your license and also check to see which are installed. The installation check will be accessing the registry. Software installation often requires elevated privileges. Try running it as administrator or have someone there who can perform the installation as administrator run the installer on your machine. If you rt-click the installer and choose Run as Administrator you should be prompted for an admin account to login as if you lack the rights. Someone in your org or on your machine with the rights can login and complete it.

@Toad.User99 Did you find any solution for this issue?

I'm struggling with the same thing; even IT support running my machine as Administrator faced the same issue.