Toad World® Forums

TOAD 32 bit Beta 61 - stil have Error "Acces Violation" using SQL Editor and TAB or Backspace

If i’m writing and editing SQL stratements and use the TAB key for one row or some rows marked as a block often i get this error. I also often get this error when i use backspace in the SQL editor.

tab is replaced with space or left as a tab?

I have first option active (fill as space) and have no problems…

Can you post the Toad.el file from your appdata folder as well as your Support Bundle?

Tab Mode is “Spaces” / 2 / Auto Indent = Y

Michael: I’ll send you the Toad.el and Bundle file today.

Attached is now the Support Bundle. But i can’t find the Toad.el file. Can you please let me know the exact Folder?
TOAD_Support_Bundle_20160518.txt (87.2 KB)

Here is the Support Bundle. but i can’t find the TOAD.EL file. Can you please let me know the folder?
TOAD_Support_Bundle_20160518.txt (87.2 KB)

I can’t upload the Support bündle, because a moderator is needed or something !? - I don’t understand, sorry…

You can send me files directly to michael.staszewskiquest.com

On May 18, 2016, at 7:35 AM, Michael.Roeder bounce-MichaelRoeder@toadworld.com wrote:

RE: TOAD 32 bit Beta 61 - stil have Error “Acces Violation” using SQL Editor and TAB or Backspace

Reply by Michael.Roeder
I can’t upload the Support bündle, because a moderator is needed or something !? - I don’t understand, sorry…

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Toad.el is located in your appdata folder. In Toad on General page in Options see the “Application data directory” value. Go to that folder and it should be there.

You can ignore the Toad.el request. The support bundle captures the most recent error and I can see the issue. There’s another recent thread on the forum for the same issue with Windows 2003. There is a problem with Toad on these old operating systems and support for them has been dropped going forward. This thread outlines the issue as well… www.toadworld.com/…/27960

Hi Michael,

please find attached the support bundle and the Toad.el file.

But what does it mean, when you say “There is a problem with Toad on these old operating systems and support for them has been dropped going forward” ? - Does that mean version 12.9 (when it will be no beta) will not longer support Windows XP Professional? - Or do you mean TOAD version after 12.9 will not support this OS?

In the last 6 months (!) nearly every week i was in contact with TOAD Support or posting problems with the TAOD beta, because of my massive problems with TOAD 12.8 on Windows XP. A few weeks ago the support told me, that the problem with the memory will be fixed in version 12.9 and i should use the beta in my production environment. I have done that and try to help you with developing a good version 12.9 by wrinting you the memory problems i have (which costs my time every day).

And now you told me, that it make no sense that i tell you my problems, because there will be no longer support for my OS? - Sorry, but why do i have a new support contract for the next 3 years and why do your support tell me, that the problem will be fixed in the next version?

Best,

Michael


Michael Roeder

Director Royalty Services

T +49 40 89085 342

F +49 40 890859 342

M +49 175 2930 342

E michael.roeder@edel.com

Edel Germany GmbH

Neumühlen 17

22763 Hamburg

Germany

www.edel.com

Geschäftsführer: Michael Haentjes - Firmensitz Hamburg

Eingetragen im Handelsregister Hamburg unter HRB 76565

From: “Michael Staszewski” bounce-mstaszew@toadworld.com

To: toadoraclebeta@toadworld.com

Date: 18.05.2016 15:29

Subject: RE: [Toad for Oracle - Beta Discussion Forum] TOAD 32 bit Beta 61 - stil have Error “Acces Violation” using SQL Editor and TAB or Backspace


RE: TOAD 32 bit Beta 61 - stil have Error “Acces Violation” using SQL Editor and TAB or Backspace

Reply by Michael Staszewski
You can ignore the Toad.el request. The support bundle captures the most recent error and I can see the issue. There’s another recent thread on the forum for the same issue with Windows 2003. There is a problem with Toad on these old operating systems and support for them has been dropped going forward. This thread outlines the issue as well… www.toadworld.com/…/27960

To reply, please reply-all to this email.

Stop receiving emails
on this subject.

Or Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Does that mean version 12.9 (when it will be no beta) will not longer support Windows XP Professional?

Yes, 12.9 will no longer support XP or Windows Server 2003. Microsoft gave up on those operating systems years ago even with extended support contracts. We don’t have development environments setup for those systems and we can’t continue to support 15 year old operating systems.

And now you told me, that it make no sense that i tell you my problems, because there will be no longer support for my OS?

The decision to drop support was only made 1-2 weeks ago. Thank you for reporting issues, bugs are seldom specific to a particular OS so reporting them is always useful. This issue is the only one I can recall in recent memory that affects a subset of outdated systems.

why do your support tell me, that the problem will be fixed in the next version?

12.8 did have a memory leak resulting in Out of Memory exceptions that has been addressed for 12.9. This AV is different. Specifically there is a problem when the edit control sends return notifications back to Toad. These notifications are necessary so that Toad knows when edits occur, when the caret has moved, etc. If I disable the notifications then the AV is fixed, but most of the Editor functionality is non-functional.