TOAD behaving slowly


One of our TOAD for Oracle 15.0 users is reporting TOAD acting slowly since 13.03.2023. Actually the software for the user has been acting slow since late 2022.
The behavior is explained with TOAD's menus and responsiveness acting slowly; navigating/clicking menu icons takes a while to receive a response and sometimes it looks as if the whole application freezes. Writing/changing code/text acts with a 2-3 second delay.

With earlier reports, we put the value "InternetAccess=0" into Toad.ini, which has fixed the general slowness issue for most of our users, yet in this occasion, that didn't help much. We recommended the user to close all connections and restart the computer. It seemed that made TOAD better, but only for about a day.

In the last few months, we also tried:

  • increasing the computer's memory the user is using from 8GB to 16GB
  • switching the computer TOAD runs on to a different port in our switch
  • reinstalling TOAD
  • tried an older version of TOAD (13, which the issue continued to exist)

It should be noted that the user is working over remote desktop at home from their laptop and connecting to a desktop machine in the office that's connected through LAN to the domain's network. All the other applications run smoothly with no slowness or freezing.
The user's network speed at home shows an average of 87mbps. The network speed of the desktop speed in the office is 1Gbps

Is there anything else we can try or check that could be causing this sort of slowness?
One thing we haven't got to try is clearing TOAD's cache (if this is something we can do?), but I'm not entirely sure what the correct way is to do this, as I couldn't find a folder to clear like most applications have.

Thanks in advance

Toad doesn't have any kind of cache, but you can reset it to a "like freshly installed" state by following these steps.

If you have access to the latest version - 16.3, that would be worth a try too. I've been focused primarily on bug fixes since about version 13.3 and have come a long way since then.


Unfortunately the reset method didn't work, however I'll see if we can update to test how the performance is on 16.3.

I'll follow up with a update later.


Seems updating to 16.3 increased the performance to the point where the user can work more comfortably.


1 Like