Toad World® Forums

14.1.114.917: very slow to start up

The latest beta takes a really long time to start up. It takes about 9 minutes before the spash screen appears. This is on a laptop with an Intel Core i7 CPU, 32GB RAM and an SSD with about 50GB free space.

Performance after the spash screen seems normal.

How can I trace/debug what happens in those 9 minutes?

With Toad version 14.0 it takes about 7 seconds for the spash screen to appear.

Regards,
Remco

Try this:

  1. Go to Options -> Online
  2. Set "Toad Improvement Program" to No.

If that doesn't help,

  1. With Toad not running, edit your Toad.ini file (steps to find it here)
  2. Add this line under [SETTINGS]
    InternetAccess=0

If that doesn't help,

  1. turn on tracing by adding this line in Toad.ini under [SETTINGS]
    DEBUG=1
  2. Run Toad
  3. Find the file User Files\logs\ToadDebug.log
  4. Post that file here.

Thanks for your quick reply.

I've tried all three options, but it's still as slow as it was. The ToadDebug.log file doesn't start until about the time when the splash screen appears, so the first line in that file is from about 9 minutes after toad.exe starts.

Here's the debug log from a couple of minutes ago:
ToadDebug.log (3.0 KB)

I'm not sure what else could be causing this then.

I think should should just reset your user files folder to start again with fresh settings. To do that, follow the steps here (skip the part about Oracle client). There is also info there about how to restore some key settings.

If that fixes the problem, you can zip up and email me your old user files folder so that I can try to find the cause and fix it. Send to john.dorlon@quest.com. Thank you.

Thanks, John. The reset solved the problem. I'll send you an e-mail with the old user files folder.

I suspect the problem is in the ToadActions.dat file. After the reset, if I copy that file from the backup, the problem returns. If I delete it, the problem goes away.

Interesting. ok, please send me that file. Maybe there is room for optimization in there.

You can keep the file trim by setting this to a low value:

Options -> General -> Save ___ Transactions per type

The default is 15, and I think that is low enough, but in prior versions, the default was 50, so maybe you have 50 or more in there.