Toad World® Forums

Toad Data Point 3.5 Automation Crashes When Running Script with Multiple Parameters against Excel

I set up a very simple automation using the ‘Set Variable’ activity to set a parameter, followed by the ‘Select to File’ activity, which runs a very simple script against an Excel tab:

select * from AutoRange_A where measure= ‘Timeliness’ and cnty_nm = :county

union all

select * from AutoRange_A where measure= ‘Response’ and cnty_nm = :county

Toad crashes immediately anytime there’s more than one parameter in the ‘Select to File’ activity and the database is Excel. If I run just one of those lines, it works fine.

It still crashes if I rename the second parameter to :county2.

This is TDP 3.5

Well that stinks. Try

select * from AutoRange_A where measure in (‘Response’, ‘Timeliness’) and cnty_nm = :county

and see if that works. Also you may want to try it in 3.6 beta. They seem to have fixed a lot of stuff in that version.

Igor and I tried this in both TDP 3.5 and TDP 3.6. Can you post your script and log file along with Excel file.

Seems like finally we were able to reproduce this issue. QAT-3923 was created to track it.

Igor.