Toad World® Forums

Toad Data Point 5.03.32 Azure Data Warehouse

OK, so I have this installed, but I cannot see any of the tables or views in the object explorer. Is there a setting that I am missing. I thought this was supposed to be fixed and working in this new version.

Well, I did some playing, and it works with the SQL connection and not the Azure connection. The release notes must be inaccurate.

From the notes:
You can now connect and build queries with Azure SQL Data Warehouse. You can use either the SQL Azure or the SQL Server connection type. An Azure SQL Data Warehouse connection is supported in the Object Explorer, Query builder, and in execution. Advanced features are not supported.
QAT-12804, QAT-13048

OK, in the newest developments, I have discovered that the Azure connection type works OK, it is just that you cannot seem to switch from DB to DB and have the database objects show up in the object explorer after switching from DB to DB.
This is also the case when switching from DB to DB in the SQL Server connection type. I can do this with our on premise DBs just fine, but not the Azure DBs (Azure SQL DB and Azure SQL Data Warehouse). This does not really make sense to me. This is at least a huge step forward in being able to naively navigate the Azure Data Warehouse objects and queries instead of having to use the janky but functional ODBC connection type.

I tried setting up numerous connections to access the different databases, but the connections get down right fussy and glitchy. I connect to one DB, but it shows being connected to another, and I cannot switch between 2 databases. The behavior is the same using the Azure and the SQL Server connections. Is there a setting that needs to be set?

Let me have a developer comment on this. We have different developers for the two providers.

Hi,

Try to connect via SQL Server Connection
After select Tree List view in Object Explorer. You can work with Azure dbs and warehouses without changing connection

Same for changing db in Editor

That does not really work. First off you cannot do it right when you have an Azure connection and a SQL Server Connection. It keeps referencing only one database (the same one) that you accessed first with either SQL Server or Azure connections.
Second, once you make the change to SQL Server as you suggested, I can see the databases as you do above in the tree view, but you cannot navigate the tables and views and such. You click on the triangle to the left and nothing happens. I tried to change back to the tabbed view and I can see the databases in the dropdown, but it does not refresh the tables and views, so the window is blank. This seems very buggy, inconsistent, and not ready for prime time.

I thought it was almost working right the very first time I made a connection after installing, but I can't remember exactly what it did.

Okay, I checked your case

When I specify database in connection then I have access only to this database in Toad.
If I leave and connected login has default database master then you have access to all database on SQL Azure server

I can't reproduce your case when you can't navigate through Object Explorer's objects. May be you have some restrictions on connected login?

So what specific permissions do you need for this to work?

I'm using login with admin permissions.