Toad World® Forums

Toad Data Point & Azure SQL Data Warehouse

Is there a way to get Toad Data Point to work with Azure SQL Data Warehouse? To be clear, I am not talking about an Azure SQL database, but the other product Data Warehouse.

Yes, the text editor works and can run and edit queries against the database.

The object explorer does not show tables. You can see views, but it is limited. The drag and drop query builder does not work well, as you cannot see tables. You can see, and drag and drop views, but you cannot see the fields, so it is mostly useless, except to select * from views, but I can do that with SSMS.

Toad Data Point is such a great tool, but it is just not working well for me with Azure Data Warehouse. Is there a setting or a permission that will make this work that I have not found yet.

I have tried to Google it, but there is almost nothing.


From investigating the documentation from microsoft it uses the SQL Server native client driver to connect which should explain why it works in SSMS. However i believe there are some internal adjustments within the driver that allow you to use it for Azure SQL DW as well. That might mean TDP doesnt seem to support those “differences” between standard SQL server and SQL DW connections.

But from what i read on the internet its possible to connect to it using an ODBC connection which you could establish in TDP by creating a new “ODBC Generic” connection type in TDP’s connection manager window. You can create a new named ODBC driver instance in windows using built in 32/64 bit ODBC administrator and just point to it from TDP when creating the connection.

Unfortunately i dont have any live connection to try this.

I was able to create an ODBC connection, but I was unable to see anything in the Object explorer, but the database drop down. I could not see tables ore views in any of the databases (Warehouse or SQL DBs).

OK, I tried something else and it appears to be working!

I first tried creating the ODBC connection in the ‘ODBC Datasource Administrator’ using the ‘ODBC Driver 13’ driver. This did not work.

I just tried using the ‘SQL Server Native Client 11.0’ driver. This appears to work.

FYI I am using sql authentication.

Yes, based on the documentation on microsoft they mentioned the native 11.0 client driver should be used. Also you must keep in mind to differentiate between 64bit and 32bit ODBC Datasource administrator… I believe that Toad detects the bitness of its own and thus opens the correct one however if you run it manually (ie from windows’ Start menu) then, for example me, i tend to make a mistake.

If you are talking about MSAS, we have a native driver for that.