Toad Data Point 6.1.0 returning results

A co-worker and I both use Toad Data point. I'm on an older version and he has installed TDP 6.1.0
Was helping him establish connections and we both ran the same query against the database. My version of Toad returned just over 11k rows in roughly 7 seconds.

After 3+ minutes, his version had only returned about 50 rows.

Has anyone else experienced this type of delay in pulling data and if so, have you been able to find a solution?


Without extra details, things possible reasons pop into my head at the moment, and assuming the counts you give are ALL rows, and not just TDP's initial fetch count:

  1. Are you both sure you're connected to
    ... the same database?
    ... Same credentials?
    ... Same Privs?
    ... Same table? (e.g. prod vs. dev)
  2. Using the EXACT same query?
  3. Is it possible that the table was updated in between query executions?

Everything is identical. Table was not updated between runs. I ran my query at the same time he ran his.

and it was just rows.. Basic query was
select * from (database table). I just had him do this to test to make sure the query would run.
There are 11k+ rows in that table.

The other thing I noticed was my version of Toad says Toad Data Point. His says Toad Workbook. I didn't know if there was a current version of Toad Data Point that does not include Workbook or if that's automatically part of the new version. I've never used Workbook so I didn't know if there was some setting that would / could be changed to allow for results to be returned quicker.

Appreciate any insight / advice you may have.


The latest versions of Toad Data Point pro edition automatically install two GUI "skins":

  • a "Classic" interface, and
  • the "Workbook" interface.

It's possible that the options in Workbook could affect runtimes, but queries within TDP Workbook should execute with similar runtimes if they were executed in TDP Classic.

You didn't mention how "old" the other's TDP version is, but to make sure comparison is truly apples to apples, you should conduct the tests with the same version of TDP. Quest has made a LOT of enhancements and fixes, just in the past year or two, so this alone might explain the discrepancy... it's advantageous to use the latest version.

The version I'm using is 4.3. (mine is the one that returns the 11k rows in 7 seconds). The other person is using what I believe is the latest version. 6.1.0. (his is the one that took over 3 minutes to return 50 rows)

I installed 6.1.0 on my machine and like you mentioned above, I saw where it installed the classic and workbook GUI. When I ran that same query, using the classic GUI, I also experienced a delay in the editor returning all of the rows from the table.

I am having exactly same issues with TDP Pro Edition 6.1.0

here are my stories:

  1. My TDP 5.4 works fine with Cloudera/Impala ODBC driver.

  2. I updated from 5.4 to TDP 6.0.5. It constantly crashes and closes on simple CTE queries. The crashes could be replicated with different users on different machines with 6.0.5 with same queries 100% time.

  3. Then I tried to update to TDP 6.1.0 and hope it solved the crash issues. But it is now running extremely slow. Results are returned a few rows each seconds. Even simple show tables in database could take more than 3 mintues as opposed to 1 seconds in 6.0 or 5.4.

I have default settings on TDP 6.1 to begin with. Then I played with local storage, cache from tools-> options. None of changes helped.

So, I am stucked at constant crash 6.0 and unbearly slow 6.1 now.
I wish I did not move away from 5.4. Now the company does not offer to reinstall the old version anymore. Extremely frustrating with 6.0 and 6.1 for now.

Any suggestions will be appreciated.

I've been having the exact same issue happen to me for months now. I had to upgrade to TDP when all my coworkers are still on 6.0. Now, when running very simple select statements (select * from table limit 50) the result is displayed at about 1 row per second. So that query takes me about a minute to run whereas my corworkers run the same query in less than 1 second. Is this happening due to the auto filter functionality? Is there a way to turn it off?

The version experienced certain performance issues, prompting its removal from the official site for download. This is one of the reasons why this version is no longer accessible - in its place, we promptly released hotfix version 6.1.2, addressing the performance issues.

We've recently released TDP 6.2 with new features and resolved bugs. You can find detailed information in the official Release Notes.

If I'm reading OP correctly, he is saying that the OLDER version is more performant.

I also experienced a lot of issues with 6.1 and stuck with 6.0. I'm testing 6.2 now (which unfortunately still has the auto filter row enabled by default with no way to disable by default).