Toad World® Forums

Toad Data Point Runaway Queries

We’ve been having issues with Toad running large background queries (select * queries on large tables). We will notice someone running a large query, we check Toad and nothing appears to be running. We check the background processes and nothing shows up. We then try to close Toad and a message appears saying “Cancel the queries that are currently running on connection [CONNECT NAME]?” We click Yes and Toad still stays up. We try to close Toad again and it finally appears to close until we bring up the task manager and see it’s process (toad.exe *32) still running until we click End Process.

We’ve tried Dell support and they were absolutely worthless. The support tech didn’t know hardly anything about Toad and didn’t understand what the issue was.

Has anyone else had this problem?

Thanks,
Michael

What version of Toad are you on? Also try the query with a 1000 row limit and see what happens (you can set limits in Tools/Options/Database/General). They have addressed some memory issues in the new beta version (3.8). You might want to try it there also.

Hi Greg,

I am running Toad Data Point 3.7.1.1011. I’ve already set the row limit to 1000. I did recently receive this email from Dell:

Hello Michael,

OK here what I found out. Toad runs a “select * from table” in the background to collect information for Code Completion when there is a JOIN used in the script. If the table that is referenced is big enough, it could cause Toad to seem hung, until it finishes running the “select *” statement.

Resolution

WORKAROUND 1:

Go to Tools | Options | Editor | Code Completion and enable the “Exclude column sample data” setting.

WORKAROUND 2:

Go to Tools | Options | Editor | Code Completion and disable “Auto list members” setting.

This is a bug and Waiting for fix in a future version of Toad for Data Point.

Thank you,

Milton Villegas

Dell Software

quest.com/support

But I’m not sure which settings he’s referencing because I do not see those settings in the location he stated.

Thanks,

Michael

Those settings that are suggested to be changed are most probably for the older TDP versions. In TDP 3.7 there is a single setting:

Tools > Options > Editor > Code Completion > General > Include top N values of columns data.

Try this.

Igor.

Thanks Igor. I will give this a try.

Thanks,

Michael

Igor,

Do you know what this setting actually does?

Thanks,

Michael

Those settings are about whether or not sample data should be included in the code completion (the check box itself) and if yes (check box selected) then how many rows of the sample data exactly should be included.

I’m not sure these are related to your problem. I just tried to clarify on the changes in the UI that support pointed you out.

Sorry if it doesn’t help.

Igor.

Just an FYI…

It may just be a coincidence, but I have not had any issues after turning these settings off.

Thanks again,

Michael

can I ask what connection type you are using?

Microsoft SQL Server.

decided to start a new thread* I’m in 3.7. I used to get this issue in previous versions of Toad connecting to Oracle, but when I disconnected from a wired connection to wi-fi. would have to shut Toad down in task manager. That doesn’t happen to me anymore, but (not to hijack) now I am being told by our DBA that Toad is apparently running two or more connections under my user (Selects via DUAL). I am limited to four connections so if I open more than 2 windows I get kicked off of every connection, and cannot reconnect AT ALL until the server rolls back whatever it was doing (unbeknownst) for me. Sometimes for longer than an hour. Is there any setting I can disable to ensure TDP is not running any “silent selects” under my user name? Sorry to digress but this was at the top when I came to post my issue and seemed similar. Happy to start a new thread. (and will also search more)