Toad World® Forums

toad for db2 freeware install error (64 bit version)


#1

devexpress.xpf.grid dll cannot be written to, make sure you have admin rights etc etc,

I start the installation from an elevated cmd prompt.if I install the 32 bit version then it installs fine.


#2

it sounds like you are trying to install 64 bit software on a 32 bit machine. I don’t think that is going to work.


#3

No , it is a 64bit machine, I think otherwyse the installer would not even start. but even if it did, this IS a 64bit machine with windows 10 64bit version., i restarted the pc hoping it would somehow release any lock in any dll but it was not the case, i keep getting the same error. I have just upgraded my pc to 16gb and would pretty much like to use it with toad.


#4

let me see if I can pass this on to the Product team.

-Mark


#5

In the past we have seen this and I believe this was a permissions issue.

Please ensure you run the command line window as administrator.

If that does not work, please try the exe installer at:

https://toaddb2storage.blob.core.windows.net/toaddb2installers1/ToadforDB2_6.5.0.125.x64.exe


#6

If you reread my post carefully you will see: “I start the installation from an elevated cmd prompt”, means from a command line window run as administrator. , in fact that was the only way to make the installer run (either the 32 or the 64 bit one) if I did it from within windows I received a permissions error and was unable to install it no matter if RUN AS ADMIN menu shortcut was used, so had to install it from an elevated command prompt. will try the .EXE version, thank you.

Can the 32 and 64 bit versions coexist?


#7

as added information, my boss tried also to install it in his PC, he had no previous toad installation , and gets the same error, so I just asked him to install the 32 bit one. of course that was before I knew there was an exe version.


#8

The 32-bit and 64-bit version cannot co-exist.

Choose the bitness of Toad DB2 that matches the bitness of your local DB2 client.