Toad World® Forums

Toad for Oracle 12.12 Always on Top

Why is Toad for Oracle window always on top of my other windows? It is always covering up my other windows. I have to minimize it so I can see what’s hiding underneath. It didn’t work this way until the update. BTW: I have three monitors.

I suspect this may be due to something in your Windows configuration. There is no option in Toad’s option base that controls this behavior, and I just looked at the content of a number of our .ini type files and didn’t see a control parm in any of them.

Does the entire Toad (parent) window always stay on top of other Win apps, or is it only certain panels (within Toad itself) that always stay on top?

Hi, I have 12.12 and I also have similar issue, it doesn’t happen with any other application.

Example: if I have TOAD open and then I click SQL*Plus, I have to minimize to see SQL Plus.

Certainly unusual, to say the least. Have either of you opened a Support call for assistance on this?

Some of our Engineers may have seen this, but if not, we need to document and track the fix.

You may want to check out this thread - it seems similar:

https://www.toadworld.com/products/toad-for-oracle/f/10/t/31813

Thanks,

Mark.

I'm having this issue after a forced windows restart with 12.8.
Please advise any direction to resolve - it's troublesome.
Thank you

I have a similar problem with Toad for Oracle 13.3.0.181 (64 bit) on Windows 10 Enterprise (1803).

SDI main window displays over all other applications and won't go to the background when using the toolbar to switch between applications. (Alt-Tab) doesn't switch out of Toad of Oracle either, but it will switch into it.

I am required to minimize the Toad for Oracle main widow, before switching to another application.

Hi Marc,

I just tried this and was not able to reproduce the problem. I assume that it works fine when Toad is first started and then the problem begins sometime later? If so, can you identify something you do in Toad that causes this behavior to start?

If Toad stays on top even after restarting it, please zip up and send me your user files folder. Directions on how to do that (and where to send them) here.

Here's what I did:

  1. Start Toad.
  2. Go into Options and change to SDI mode. Toad Restarts
  3. Open Schema Browser or some other window.
  4. Try ALT+Tab to go to another app. Works.
  5. Move some other opened windows around to see if they are on top of Toad, they are.

Oh, and by the way - I saw your identical post, replying to a similar thread. There is no need to post both, we see everything.

John,
I have rebooted my computer, and the problem seems to have gone away. Switching from the taskbar, alt-tab, and task view all work now.

OK. I wasn't certain if old posts were watched.