Toad World® Forums

Toad for Oracle DBA Suite - 12.8.0.49 and Creating Scripts for Users or other objects

I can no longer create scripts from an existing user or object. Also, migrating to another database instance does not work. No error just doesn’t do it. I used to be able to do this with previous versions.

I have seen this behavior in older versions when the ToadActions.dat file got corrupt, but I haven’t seen this with newer versions. WIth Toad not running, try renaming that file, then restart Toad. The file is in your User Files folder. The easiest way to get to that folder is from Toad’s options window. Go to the “General” node on the left. On the right, click the “Open Folder” button (in the “Application data directory” box). Close Toad before you rename ToadActions.dat.

Tried your solution John - still does not work.

maybe I am misunderstanding what you are trying to do. Could you post a screen shot or two?

Here is what I do - in the Database Browser Window, go to Users, Right Click User, and Select Create Script.

If I do the same thing but for an object like a table it works like it used to.

Linda
Sscreenshots.docx (109 KB)

Hmm. It is working for me. Whenever it has not worked, the above steps would fix it, so I’m a bit at a loss. Going to a clean set of user files might fix it. That’s in the main menu -> Utilities -> Copy User Settings. But of course going that route, you will lose all of your settings.

What about if you go to the Schema Browser, then pick your object, then go to the Script tab? Does it work from there?

If you want, you can zip up your user files folder and email it to me, and I’ll try to find the problem. john.dorlon@quest.com

Got it…here is what I did. Went to Utilities\Copy User Settings\ browsed to an older install. I have a 12.6, 12.7, 12.7(1), 12.7(2), 12.8. I tried the 12.6 and restarted. It appears to be working now. I did not choose the 12.7 ones as it has been an issue for a while now - but I normally do not do this process.

Thanks for your help. I wonder if on one of the earlier installs or upgrades it corrupted something.

Linda

I’m glad you got it working. Yeah, it could have been that when you renamed the file the first time, we pulled it out of an older version’s settings. I’m not sure how the corruption happens.