Toad World® Forums

Toad startup is taking longer than previous version

I installed the new version of Toad for Oracle 12.8.0.49 and now it seems as though it takes about 20 seconds before it completes loading and I’m able to use it. Is anyone else having this issue or know how I can resolve it? I know 20 seconds doesn’t seem like a long time but when you’re waiting to check on a system it feels a lot longer than it sounds. Also it didn’t exhibit this behavior in the previous versions, I’ve installed, going back to 12.1.

Toad for Oracle 12.8.0.4

Windows 7, Professional

Thanks

Dwayne

For me, it only takes Toad 12.8 about 7 seconds to start, connect to a database, and get ready for me to start typing in the Editor.

To speed yours up, the first thing we need to do is find out which part of the startup is going slowly. WIth Toad not running, edit your Toad.ini file, and add a “DEBUG=1” right under [SETTINGS]. Save the file, then start Toad and close it again when it finishes starting up. Then in your User Files folder, you’ll have a file called ToadDebug.txt with some timings in it of various startup events. Post that file here. (and then you can take “DEBUG=1” out of Toad.ini again.

I did this but now, the program starts right away but I get an empty Toad Memory Usage window that pops up. I’ll try to put both the file and the screen shot here. If I remove the Debug=1 and restart Toad, it goes back to the extended startup and the popup doesn’t show.

12:27:28:616 Initializing application
12:27:28:616 Creating GlobalDataModule
12:27:28:648 Performing Toad’s startup tasks
12:27:28:741 Setting Toad help file
12:27:28:741 Setting global options
12:27:29:786 Creating main window
12:27:29:786 Create Bitmaps Form
12:27:29:974 Restoring dock layout
12:27:30:415 Checking for Spotlight
12:27:30:415 Checking for SQL Impact
12:27:30:415 Initializing Team Coding
12:27:30:431 TTeamCoding.CheckSupport
12:27:30:431 TTeamCoding.CheckSupport
12:27:30:431 Building quick scripts menu
12:27:30:431 Building external tools menu
12:27:30:493 Enabling features based on license
12:27:30:977 Restoring size and position
12:27:30:994 Performing Toad’s command line tasks
12:27:30:994 Application.Run

Well that’s unexpected! I see above that you aren’t making any connection to the database at startup. What about when it comes up slowly - does it seem like the slowness might be in the database connection and background queries that come with it?

I don’t make a connection to any of my database upon startup of Toad only after it’s up. This delayed time is happening just from simply starting Toad itself.

If you look in your User Files folder, do you have any really large files? (ToadActions.dat and anything with an XML extension would be a likely suspect).

If you want, you can zip up that User Files folder and email it to me, I’ll be happy to it here with your settings.

I don’t know enough about these files to feel comfortable sharing them out at this time, but I can tell you that the largest file in that folder is JumpTargets.dat at 5MB. The next largest file is ToadActions.dat at a mere 539KB and they decrease in size significantly after that.

That all sounds pretty normal. Do you think you might have previously saved/loaded a file to/from a location on the network that is no longer available? I don’t know why that would matter only when the DEBUG setting is not present.

If you want to email me the user files folder directly instead of posting it here, you can send it to John.Dorlon@quest.com. Mostly it’s just Toad’s settings in there, but there is also SQL history. There shouldn’t be any data that you’ve selected in there though. Passwords, if saved, are encrypted, and I can’t decrypt them.

If you don’t want to share it, that’s fine. Another thing you could try is in Toad’s main menu, go to Utilities -> Copy User Settings. There is an option in there to “Reset to a clean set of user files” which would undo all of your settings in Toad and revert to an “out of the box” state. After that, you can still bring back your old connection history, etc, - they are saved in a renamed “user files” folder.

I don’t recall saving or loading a file from a network location, that would still be open. I’ve look at Alert logs for instance, but I always close the window when I’m done. I’ll send you a zipped version of my user files directly as you suggested, shortly.

Are you by chance running Toad 32-bit on a 64-bit OS? I just noticed the same thing today but did not have any problems when I had the 64-bit version installed. I’ve got a VM with a 32-bit OS and Toad runs fine.

From: dwayne.sawyer [mailto:bounce-dwaynesawyer@toadworld.com]

Sent: Tuesday, May 24, 2016 9:46 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad startup is taking longer than previous version

RE: Toad startup is taking longer than previous version

Reply by dwayne.sawyer

I don’t recall saving or loading a file from a network location, that would still be open. I’ve look at Alert logs for instance, but I always close the window when I’m done. I’ll send you a zipped version of my user files directly as you suggested, shortly.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Hi Brad, Yes actually I do have the 32-bit Toad on my 64-bit Win 7. However, this didn’t cause an issue in my previous version of Toad for Oracle. But I will see if I can test that out as well. Thanks.

I remember now, that I get an error when using the 64-bit version because I don’t have a 64-bit client. All my Unix based databases are on 32-bit connections. I’ll add a 64-bit client to my workstation and see if that helps.

Yes, that sounds like your best bet. Please let us know if this takes care of the slow startup times.

From: dwayne.sawyer [mailto:bounce-dwaynesawyer@toadworld.com]

Sent: Wednesday, May 25, 2016 1:30 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad startup is taking longer than previous version

RE: Toad startup is taking longer than previous version

Reply by dwayne.sawyer

I remember now, that I get an error when using the 64-bit version because I don’t have a 64-bit client. All my Unix based databases are on 32-bit connections. I’ll add a 64-bit client to my workstation and see if that helps.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

So far, so good. I’ll run with the 64-bit environment for a few days and report back. Hopefully, this solves my issue.