Toad World® Forums

Toad for Oracle version 12 startup very slow


#1

I’m running TOAD for Oracle version 12.12 on a Windows 10 VM.

The Windows 10 is 64bit, the Oracle client is 64bit and I’m running the 64 bit version of TOAD. TOAD is very slow to launch/startup. I don’t automatically connect to any databases, I’m referring to the time it takes from double clicking the Toad for Oracle icon on the desktop to when the list of database connections are presented. I recently worked on a different VM that had a older version of TOAD installed (version 11 something) and the startup time was much shorter which made me realize that the issue I’m facing appears to be version specific.

I was going to upgrade to version 13 and saw another thread in this forum where someone indicated that 13 was slower than 12 (https://community.toadworld.com/products/toad-for-oracle/f/10/t/35313).

I set DEBUG=1 in the toad.ini file, and below is the output of the ToadDebug.txt file. I double clicked the Toad icon at 12:04:00. Notice that the debug log doesn’t show anything until 12:05:06 and it finally came to the point where I can select a database to connect to at 12:05:40.

I’ve worked with TOAD support on this before and we checked the usual suspects, McAfee, etc., and none of that was the problem. I’m hoping that someone here can help me figure out what might be going on.

12:05:06:941 Toad.dpr Line 1
12:05:06:941 User Profile checking command line parameters
12:05:06:941 User Profile checking settings location INI
12:05:06:957 AppData Location: C:\Users\axp1\AppData\Roaming\Quest Software\Toad for Oracle\12.12
12:05:06:957 User Profile refreshing client files
12:05:32:346 Creating QuestKey Factory
12:05:32:346 Parsing command line parameters
12:05:32:346 Creating Toad mutex
12:05:32:362 Loading Toad settings from Toad.ini
12:05:32:518 Initializing application
12:05:33:128 Creating GlobalDataModule
12:05:33:221 Performing Toad’s startup tasks
12:05:33:221 Setting FPU exception mask
12:05:33:237 Setting Application properties
12:05:33:237 Desensitizing drag & drop
12:05:33:237 Creating GUISettings folder
12:05:33:237 Setting Toad help file
12:05:33:237 Checking for critical files
12:05:33:253 Getting license information
12:05:33:253 Verifying Toad license
12:05:33:253 Checking existing QuestKey licenses
12:05:33:393 Found permanent license
12:05:33:393 Saving edition to SettingsLocations.INI file
12:05:33:425 License status: Registered
12:05:33:425 Checking entitlement period
12:05:33:425 Setting global options
12:05:33:425 Checking installer induced policy restrictions
12:05:33:487 Checking Toad Group Policy induced policy restrictions
12:05:33:503 Toad Group Policy restrictions do not apply
12:05:33:503 Checking runtime intelligence opt-in
12:05:33:503 Opted out of runtime intelligence reporting
12:05:33:503 Has internet access
12:05:33:503 Starting settings auto-save thread
12:05:35:518 Creating main window
12:05:35:518 Create Bitmaps Form
12:05:36:050 Restoring dock layout
12:05:36:581 Checking for Spotlight
12:05:36:581 Checking for SQL Impact
12:05:36:581 Initializing Team Coding
12:05:36:596 Building quick scripts menu
12:05:36:612 Building external tools menu
12:05:37:784 Enabling features based on license
12:05:38:471 Restoring size and position
12:05:38:471 Ribbit!
12:05:40:700 Performing Toad’s command line tasks
12:05:40:700 Application.Run
12:05:51:371 End DebugLog


#2

Hi Abe,

It looks like the majority of time is in refreshing the client files. In this process, Toad is simply copying key files from its installation folder to your local user files folder (listed in “AppData Location” in your debug file). My first set of questions would be:

  1. Do you still have a previous version of Toad installed on the same machine that you can try the same startup process?
  2. If so, does that version also start up slowly?
    Internally, we have noticed situations in which Windows 10’s file copy ability is significantly slower than it was in previous versions of Windows. Other people have reported similar problems online (Google “copy file slow windows 10”). There are, of course, lots of proposed solutions out there; but perhaps something from the following Microsoft pages may help in your situation:

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/copy-speed-very-slow-in-windows-10/950c8f96-d9de-41e2-8d35-977944eb5c01

or

https://answers.microsoft.com/en-us/windows/forum/windows_10-files-winpc/windows-10-pro-extremely-slow-data-transfer-and/7c37d695-c65d-48f0-86a0-d0ee5beaf82d

If they don’t, you can also try to reset your user files in Toad to a clean set by selecting “Utilities -> Copy User Settings -> Reset to a clean set of user files from the base installation”.

Let us know if it continues to be a problem.

-John


#3

John,

I’m still experiencing this problem. I’ve upgraded to version 13.0.0.80 and I’ve reset the user files per your suggestion but TOAD is still very slow to launch.

I don’t have older versions of TOAD running on Windows 10. I have v12.5.1.1 on a Windows 7 VM and it launches quickly on that VM. I also have v12.11.0.95 on another Windows 7 VM and it is slow to startup. All VMs are configured with the same amount of memory, CPU and diskspace.

I believe it was sometime after I upgraded from v12.5.1.1 that I started to notice a slowdown when launching TOAD and it has gotten worse with later versions.

Are you not experiencing the same problem internally when launching TOAD on Windows 7 or Windows 10 VMs?

Abe


#4

Hi Abe,
I am also facing the same issue for a while.
What I have found using Procmon is that most of the time in TOAD startup is spent in writing to a “.tmp” file in the AppData\Local\Temp folder. Quite a bit of time is also spent opening and closing sechost.dll file.

In my case opening TOAD took 10.3 secs out of which 7.2 secs was spent writing to the tmp file and .8 secs was spent in sechost.dll.

I have reset my User Files but still TOAD is very slow to open.
I have 12.12.0.39. If Quest provides me PDB files then I can share the stack trace where all the activity is happening and this issue can be resolved more quickly.

Abe… if you need help using Procmon please let me know. Most likely you have the same issue as I do.


#5

You can probably look at that TMP file with notepad to see what’s in it. Let me know and I’ll see if there is something I can do to speed that up.

We don’t use PDB files, I don’t have any to offer.