Toad World® Forums

Toad v11 Schema browser LH tab order wrong - bug

Hi,

This is a minor, but fairly irritating bug in v11.

I’ve configured my schema browser to show the tabs (multi-lined) in the following order:

Tables
Views
Packages
Procedures
Functions
Triggers

However, when I first launch the schema browser (which is my default window to launch when I open a new session) the order is as follows:

Tables
Views
Procedures
Packages
Functions
Indexes

I right mouse click on the tab icon area and click configure, but the tabs are already listed in the right order. Clicking on ok then puts the tabs in the right order.

I’ve tried closing the schema browser with the tabs in the right order and relaunching it, but that comes back with the wrong order again. I’ve even closed Toad down entirely (making sure that the last schema browser closed had the tabs in the right order) and relaunching, only for the tabs to still show up in the wrong order.

Why are the settings not being applied when the schema browser is launched? Is it a bug, or is it something that I haven’t got set right in the options?!

This worked fine in v10.6.

ETA: I’ve tried restoring the default order and then re-ordering and that didn’t work - I still have the same issues with the ordering not taking effect until after I’ve opened up the config and clicked OK without amending anything.

Message was edited by: Boneist

Am I the only one that’s seeing this problem in v11?

It’s really irritating having to “configure” the tabs everytime *{:frowning:

Message was edited by: Boneist

Sorry, I missed your first post. It’s a bug.

This issue has made it to me through Quest Support, and it’s fixed for the
next beta.

You might be able to work around it by going into the config screen, and moving
all the non-visible SB tabs to the end of the order.

I’ve attached a picture that shows the order of the tabs when I first open the schema browser, and then what the Configure Browser Tabs is set to when I open it.

I haven’t made any changes to the configuration, but when I click on “OK”, the tabs shift to their correct positions.

My options are remembered, when I close Toad and reopen it again, they’re just not applied.

Anyone? Bueller?
toad_tabs_issue.jpeg

This has been reported by Quest support and has been logged as a bug. It will
likely be fixed in an upcoming beta.
image001.jpeg

This has been reported by Quest support and has been logged as a bug. It will
likely be fixed in an upcoming beta.
image001.jpeg

This has been reported by Quest support and has been logged as a bug. It will
likely be fixed in an upcoming beta.
~WRD000.jpeg

Thanks for the update - appreciated *{:slight_smile:

Thanks for the update and suggestion - I tried it but it hasn’t helped *{:frowning:

One other thing - the Editions tab is ticked, and I can’t untick it - probably because I’m connected to a 10g db (I don’t have access to an 11g db, sadly). Is that likely to be having an effect?

You’re welcome. Sometimes the TFO posts don’t make it to my inbox,
I’m not sure why. If it ever seems like I’m ignoring you, I’m
not. Feel free to email me directly.

I don’t think Editions is the cause of the problem, but if you want to
check, you can go into Toad.ini (with Toad not running), find the [PAGESHOW]
section, and put a 0 on the ‘Editions’ line.

As you suspected, that made no difference. Oh well, worth a shot!

I can confirm this has been fixed in the latest Beta (11.1.0.5).

Thanks! *{:slight_smile: