Toad World® Forums

toad version 12.8.0.49

with the latest update to oracle 12 c I can no longer see grants in the script of a table. Is there a setting that needs to be set. I can see the grants in none 12 c instances.

It works for me. If you are getting the script in the Schema Browser RHS Script tab, click the first toolbar button on that tab, then make sure that the “Grants” checkbox is checked in the dialog that appears.

If that’s not it, go to Options -> Startup, and make sure that “Check for access to DBA views” is checked (restart Toad if you change this).

If you still aren’t getting the grants, turn on spool SQL. (database -> Spool SQL -> Spool to screen). Then go to SB-Tables-Scripts and so it will generate a script, and post the Spool SQL contents here.

Thank you , Options -> Startup, and make sure that “Check for access to DBA views” did the trick.