Toad World® Forums

'Type' object not appearing in the Schema Browser drop down list

Good Day!

Environment: TOAD 12.6.0.53 TOAD For Oracle Xpert Edition Add-Ons: DB Admin Module

I have a user that has several ‘Types’ created in her schema.

However, when she opens a Schema Browser window and clicks on the drop down for object types, the object ‘Type’ does not appear.

I clicked on the Browser Style -> Configure LHS Object Types and ‘Type’ was not even in her list of types to select or deselect. YIKES!!!

It works fine in my version and I checked that we have the same version, options and Add-Ons.

Any suggestions as to why she can’t see that particular object, but many others?

I didn’t check to see exactly which ones she could see or not see versus my list because we were focused on this particular one.

Thanks in advance for any help!!!

-gary

Types should always be in that list. This is just kind of a wild guess, but…the grid isn’t filtered, is it? Like this? If so, click the ‘x’ to clear the filter, then “Types” should show up in the list. Then you can check the “visible” column to make it show up in the SB.

BrowserTabs.jpeg

If that’s not it, please post a screen shot of what this dialog looks like for you.

John

Thanks very much for your quick response. My user has been out for a few days so I couldn’t see if the above filter was set. It was not.

We can’t find any other filters being set.

She has the CREATE TYPE privilege granted through a role.

She has several TYPEs create in her schema.

We can’t see ‘Type’ in the ‘Configure LHS Object Types’ drop down or the drop down for object types in the Schema Browser LHS.

Any other suggestions are most welcome!!

Thanks again for your help!!

-gary

John

Sorry I forgot to ask you. Where would I set that filter you show in your reply?

I couldn’t find anywhere to set that filter.

Thanks!

-gary

That filter is a built-in feature of the grids in Toad.

If you hover your mouse over the column header, a button will appear on the right hand side of each column where you can specify the filter. But you really shouldn’t do that for this grid.

I don’t see any reason why TYPES should be excluded, but let’s try this to revert the SB object types back to default:

  1. Go to Options -> General and click the “Open Folder” button next to “Application Data Directory”.
  2. Shut down Toad.
  3. In the folder that opened in the first step, browse down to the “User Files” folder and find the file Toad.ini.
  4. Email Toad.ini to me before making any changes. john.dorlon@quest.com. If there is a problem in there, I’d like to try to fix Toad so this doesn’t happen again.
  5. Edit Toad.ini with notepad.
  6. In Toad.ini, find and delete these sections: [PAGENAMES], [PAGEORDERS], [PAGESHOW]. There should be about 50 lines in each of those sections.
  7. Save Toad.ini and restart Toad