Toad World® Forums

Unable to OPEN TOAD, toad error


#1

Hi , I installed the toad 13.0 version on Friday . I ran the .exe file as “Run as System Administrator” and it passed all the validations check and successfully installed.

But when I tried open a test environment I am getting toad error “Can’t initialize OCI. error -1”. I installed this same as my previous version 12.*.

Another thing I noticed is the TNSNAMES editor is showing as “X” instead of "check "


#2

Did you install the same bitness (32/64-bit) version as 12? It kind of sounds like you may have have installed 32-bit for v12.12 and then installed 64-bit for v13 (or vice versa).


#3

Dennis,

I just double checked and its 32 bit version for 12 and 13 toad versions.


#4

Do you have multiple Oracle Homes setup on your machine? If so, look under the ‘Connect Using’ drop down and see if it’s using the same Oracle Home for both 12 and 13 - it’s possible it’s defaulting to an invalid Oracle client. Click the […] next to the ‘Connect Using’ field and verify everything is mapped correctly for the Oracle Homes. Also, when you click on the TNSNames Editor button do you see a list of your db’s? If not, can you could try opening/loading the active tnsnames file on your machine.


#5

Dennis,

I checked and it s connected to the same oracle home as version 12. Only difference between both versions in the mapping is in R12 tnsnames and sqlnet.ora is mapped to the right locations but they are blank in R13. I cant click on the TNSNames editor button as its disabled/greyed out


#6

You should be able to open the TNSNames editor by going to the menu Utilities > TNSNames Editor - from there you should be able to load your active TNSNames.ora file.


#7

If that doesn’t help, you can send me the support bundles offline for both 12.12 and 13.0 (to Dennis.Paulus@quest.com) and I’ll see if I can notice any noticeable differences.


#8

When I tried to open the tnsnames editor from menu>utilities I am getting error " A TNSNames.ora file was not found."

What support bundle files are you asking for ? Is the executable I downloaded ?


#9

Right - that appears to be the issue - for some reason your TNSNames file is not mapped. In that window, you can click on either of the first two button - [Open the Active TNS Names File] or you can open it manually with the [Opens a TNS Names file] and then navigating to it on your machine.

Support Bundle can be found by going to Help > Support Bundle


#10

Might not be your situation, but sharing my notes Justin case they might be helpful.

I had some trouble editing my tnsnames.ora & sqlnet.ora after installing TOAD on a new windows10 laptop from my employer. This turned out to be a permissions issue.

Even though TOAD had installed correctly (thanks to software that automatically elevated its privileges for the install), I had to run it elevated to access my sqlnet config files.

For me, that meant when running TOAD, first Shift+RtClick, then select Run Elevated. Click “OK” to “I need to run an Application”.

Then to get the LDAP drop-down working, I had to edit both the sqlnet.ora and ldap.ora (even though they were already fine). I readded all the ONN servers into the LDAP, ordered them correctly, then saved that file. Then re-ordered the NAMES.DIRECTORY_PATH for the sqlnet.ora and saved that. And hey presto, my LDAP drop-down appeared.


#11

I’ve had some problems in the past with having both 12cR1 and 12cR2 client installed at the same time. If you have both, try temporarily renaming one of them and see if that helps.


#12

Thanks John for the solution, but I don’t have multiple clients.

Finally I am able to see the tnsnames editor , when I turn off the UAC and run the toad.exe as normal user not “Run as system admin” . But I am still getting OCI initialize error .


#13

In the login window there is a button like ‘…’ next to the “Connect Using” dropdown. It may indicate some problems.

Also, please post your support bundle as Dennis requested. You can send it to me if you don’t want to post it. john.dorlon@quest.com.