Toad World® Forums

Unknown database questdebug, while trying to debug a stored proc

Hi,
I’m ending up in the following error
unknown database questdebug
when I tried to debug a sample procedure. I’m able to successfully execute them though. only the debug doesn’t work.

I’m using Toad for MySql 5.0.0.345

I suspected the debug mode uses an instance of the database, so I created an instance called questdebug to see the error change to something else. The new error is now
Table ‘questsoftware.debugbreakpoints’ does not exist.

Did anyone encounter these problems. and how did you work around them. I suspect the installation should create this debug database, which for some reason did not create.
Any help would be appreciated.

There are a couple of objects that needs to be created on the server for debugging to work. Toad should create these automatically though the first time you try to load the debugger.

What version of MySQL are you using?

Hi …

I just had the same problem.

I’m using Toad for mySQL v 5.0.0.3.4.5 with mySQL v 5.1.50.

the quest debug tables have not been created.

Did I miss a specific step during the setup?

any help much appreciated.

(Hoping I don’t have to wait too long for an answer) :slight_smile:

TIA

Fred

These should be created automatically. One thing I would try is to download the 6.0.1 version of Toad for MySQL and see if that works for you.

Hi Mauritz,

thanks for your quick response.

Is there no script available that I can run independently?
And why has the database no been created in the first place?

And as it relates to your suggestion to install version 6.0.1…
I tried to install v 6.0.1 on the same machine (with Toad4mysql vers. 5.0.0.3.4.5)
but the installation stops after the first user dialog and v6.0.1 does not get installed :frowning:

Do I have to uninstall v 5.x first?
And what happened with my named scripts and reports that I have created in v 5.x when I uninstall it?

I know… many many questions :slight_smile:

Maybe there is a simple answer to those 2 questions.

Thanks

Fred

You can keep your 5.0 and install 6.0 side-by-side to it.

For installation issue. Please try silent install.
1.Download the .exe installer to your local drive, say c:\temp

2.For windows 7 and Vista users, make sure you open command window with admin privilege. You can type “cmd” in start menu, and right click “run as Administrater” to invoke it.

  1. Run the silent install command
    “ToadforMySQL.exe” /S /L*v “c:\temp\installLog.txt”

  2. Wait about 15 minutes and check the log file to confirm the install complete successful.

After 6.0 is installed, you can launch it and choose to migrate settings from version 5.0 so that all you preference is kept.

If for some reason the install does not complete please let us know what the contents of the installLog.txt file is so we can hopefully fix it.

Hi
I just installed version 6.0.1 according to the instructions from Kiki in te previos postign and it appears to me it work. I could launch the new version (on one of my computers).

I will trying to debug a SP (questdebug database) tomorrow and will keep you posted.

Thanks for the help

Fred