Toad World® Forums

Visual Studio Online - Team Coding

Is there documentation for Team Coding via Visual Studio Online (TFS) using version 12.10.030 of Toad?

if you go to HELP and then search for TFS you will see the current information for this.

-Mark

Help section gets you definitely on your way, but please be aware that Toad applies a strange logic to build the actual connection URL to your VSTS project.

During my tests of this feature I ran into the problem that HTTPS connection always resulted in the error message: 15:23:25 Output: Error logging into Microsoft Visual Studio Team Services.

After several hours of troubleshooting I finally found out (thank you fiddler :-)) that in the actual HTTPS URL some dot ‘.’ where wrongfully replaced with a comma ‘,’. For some, to me, unknown logic the decimal separator character is used to build the URL string. So changing in the options (General) the decimal separator to a dot made the connection work properly.

Enjoy

Björn

Hi Björn,

I suspect you’re seeing this issue happen in the section of the call that specifies the API version of the call. This section is required when making the call into VSTS. If your local settings are defined in which the decimal separator is a comma on your machine, I could see how this might happen.

I’ll get this fixed for the first beta of the next Toad version. In the meantime, keeping the decimal separator defined as a period in your Toad options should continue to keep you working. If you see this happening anywhere else in the VSTS URL string, feel free to let us know.

-John

P.S. As an aside: you can definitely use Fiddler to trace calls if you wish – it is a great tool! However, for simplicity sake within Toad and Team Coding, all you need to do is enable VCS Debug logging in the Team Coding configuration screen. It should output all the calls it makes to the VCS, as well as the VCS’ responses, to a debug log which you can later review.

Hello John,

Thx for the quick feedback.

Indeed the (first) call that fails is the API version. When the decimal separator is set to a comma, Toad sends somewhere ‘2,0’ instead of ‘2.0’.

Concerning your remark on the debug log, I tried that before firing up Fiddler, but the log message is/was not very helpful nor the output in the console window. I just did a quick test and I only get the following in the log:

==================================================================
Time Stamp: 06/22/2017 10:43:31:332
Getting Project List

Anyway, most important is that the fix is scheduled :-).

Cheers

Björn