Toad World® Forums

Where are the generated statspack reports from toad?


#1

Usually when running a statspack report in Oracle, a report is generated in the …/…/rdbms/admin/ directory. When I run it in toad, I see the Snap ID and snap times. Instead of getting the graphed version of the results in toad, I would like to get the .lst version that Oracle generates. Are these stored in a different directory on the database server when running statspack via Toad?

Thanks!


#2

If you want to see an actual statspack report, you can rt-click on a pair of snapshot ID’s and choose “Run Statspack Report…”. The first time you do this, Toad will need to copy some SQL Files from the Oracle server’s RDBMS\ADMIN folder.

The data collected by statspack is stored in database tables in the PERFSTAT schema. When you run the report, you can save the output wherever you want. Toad makes a folder called StatsPack Reports under your User Files folder and stores them there.


#3

Thanks for your quick response John.

I followed your instructions. Now I am getting this error:

Cannot create file “C:\Users\me\AppData\Roaming\Dell\Toad for Oracle\12.6\User Files\StatsPack Reports\11gR2\Run_TEST:1521\TESTBOX_595_596.sql”. The filename, directory name, or volume label syntax is incorrect

I am not sure where to continue from here.

Thanks!


#4

Oh, looks like you are using Direct Connect.

Toad is trying to save a file with the connection as part of the file name, and windows doesn’t like filenames with colons in them. I’ll fix that.

In the mean time, as a workaround, make a TNSNames.ora entry for this database and use it to connect rather than the “Direct” tab on Toad’s login window.


#5

Looks like this bug was actually fixed on 6/11/2015, so it will work correctly in 12.8 which should be available in a month or less. I don’t know the exact date.


#6

Hi John,

I created a TNS entry and successfully logged into the database. However, I am still getting the same exact error mentioned above. So you think this issue will be resolved in the next release? I am currently on 12.6.

Thanks!


#7

You need to do more than just create the TNSNames entry. You need to connect with it. Click the login screen to “TNS” and find the name of your entry in the dropdown.

Yes, it works in the current 12.8 beta (but you’d need to have 12.7 installed to run it).


#8

Excellent, that worked! I finally got the report I was looking for. Thank you John!