Toad World® Forums

Why is numeric value returned in scientific notation

Guys,

I am new using Toad. I wanted to know if someone can guide me through making Toad display a numeric value NORMAL. I am getting a result like this 8.3106E+12 and I want the full number, How do I acomplish that? Thanks.

options -> data grid -> uncheck show numbers in scientific notation

PS - all I did was a help search on scientific and there it is. The help has a search box in lower left corner - and newer version of toad have smart help search on main toolbar called jump list - either would have told you this …

Bert, I tried that. I unchecked it and they still showed in scientific notation. I also restarted Toad and no change. I was wondering if there was some other way. Thanks.

works for me - and I don’t have to restart toad, just change the option and press f9 again

so need far more details. editor or schema browser, what version toad, what version oracle client, what method to execute query if in editor (f5 vs f9 - they are different), and so on …

you must be doing f5 (exec as script) which causes toad to run editor contents in our separate script execution engine - and which does not seem to honor the setting

that might be a bug - I’ll let Michael or Greg answer that one :slight_smile:

PS - since you said you are new to toad you do need to read help about difference between f5 and f9 - major concept to master asap :slight_smile:

Bert, you were absolutely right. I was doing F5 instead of F9. I will defintely read about it and understand the differences. Thanks so much.

Toad World has lots of content on this too:

www.toadworld.com/.../10-things-you-must-know-about-toad-s-editor-part-2.aspx

has this very good description:

**9. F9 versus F5 Statement Execution **


Statement execution in Toad is pretty straightforward. If you want to execute a single statement, always use F9. If your editor has multiple statements and you are not using statement delimiters (; or /), then you will need to use SHIFT+F9 or highlight the statement you want to execute and use F9. If you have multiple statements and you want to execute them all, then use F5. Be sure to read Bert’s blog series on Toad’s script execution to learn more about this powerful Toad feature.

Will do. I appreciate your help :slight_smile:

I know this is an old post but I am having the same issue with values being displayed as scientific format when the setting is standard. I read your information below but this issue was not addressed. Was this ever resolved?

I don’t have this option is there another way?

If you run your queries with F9 (or click the “execute/compile statement at caret” button), then this is controlled in Toad’s main options window: Options -> Data Grids -> Data -> Display Numbers in Scientific notation.

If you run your queries with F5 (or click the “execute as script” button), large numbers always come back in scientific notation. A workaround would be to use TO_CHAR() around the columns in question. Another workaround for F5 is to add this at the top of your script:

set numformat 999999999999999999999999

If you get any results with #'s instead of digits, you can add more 9’s above.

Of course, this will affect every numeric field, and all of your numeric fields will be as wide as the number of 9’s you specify with SetNumFormat…so, in this example, all numeric fields in the script would be 24 spaces wide.

1 Like