Toad World® Forums

window visibility issues in SDI mode

One problem I have is going from 2 monitors with Toad on 2nd display, to one monitor. When I open a new window on my single monitor, it’s sometimes not visible. I see no way to move the window so I can see it. The only solution I’ve found is to use Toad’s Window bar to maximize it when I need it, and then minimize it.

The second problem is a sporadic one. Sometimes, when I open a new window, it pops up and then another of my existing windows pops up in front of it. This also sometimes happens when I’m working in an existing windows, such as Session Browser, I click in the current window and one of the windows behind it pops to the front. I haven’t seen any discernable pattern since it is so sporadic (I’m even wondering if it has happened since I upgraded to the .14 beta). I’ll update you if I see any pattern or possible cause, but just wanted to mention it in case others have seen anything similar.

Hey Dale,

I’ve put some code into place for the next beta that should fix the first issue. I forgot about that one when I was making changes for SDI mode – sorry about that! Feel free to let me know if you continue to run into any issues with it.

As for the second issue, I’ve noticed that sporadically myself. I’m not entirely sure what’s causing it, and I haven’t seen it recently. When I last went down that rabbit hole, it appeared to be happening down in Windows API; but I’m not ruling anything out. This issue is definitely on the burner.

-John

Thanks John.

The 2nd issue has occurred twice this morning, both times I was in SB tree view expanding a node that took a few seconds. I still can’t reproduce at will, so maybe the few seconds has nothing to do with it.

happened twice more, when I started a Data Compare window, and just now when I opened a new connection that started an SB window (in this case I had a Describe window open, fyi)

Let me know if it’s useful to continue reporting these incidents.

Hey Dale,

No need to keep posting when it happens. I think I have enough to go on. I’ll let you know what I find.

Thanks!

-John

John, I still have issue of, when going from 2 monitors to 1 monitor, some new windows are not visible and I still have to Maximize them to see them.

Hey Dale,

Ugh! I thought I had that issue resolved. I’ll look more into it on my side. Sorry about that!

I had also made a slight change for this last beta in regards to the second issue you were experiencing. Are you still experiencing the issue where windows are going back behind others since the beta yesterday?

-John

Hey Dale,

Yep, I had missed a piece of code that was resetting the form’s position after I had already set it. Sorry about that!

I’m assuming you have the options set in Toad to save the form’s position for the forms in question? If so, this should be fixed for Thursday’s beta. If it still happens for you after the next beta, let me know. Based on my local testing here, forms appear to be opening correctly now on their proper monitors. That being said, if you originally opened a form on Monitor 2, move to an RDP session that only has one monitor, open the same form, and then move back to an environment with two monitors, the form will open on the first monitor (since that’s where its position was last saved due to the RDP session).

-John

John, I still have issues with off-screen windows. My situation is when I connect remotely to my work computer - I’m connecting via VDI to a terminal server, then RDP to my desktop. Norm had sent a link with various options. 1) change resolution - can’t when connected remotely, 2) select Move from rt-click options - not available on Toad windows, 3) cascade windows - I tried this and stacked and side-by-side, none show the off-screen window, and these are more painfully disruptive than #4 (the undo option is very handy), 4) Maximize - this works but not pretty.

The other issue with current/new window losing focus still occurs, though less frequently. Most recently, I opened a new Import window which did not come to the front, and one other situation which unfortunately I don’t recall exactly what I was doing, but it wasn’t opening a new window. I was working in a window and it “disappeared” - found it behind several other windows.

I just tested starting a new Toad instance and opening the problematic window and it now appears on my current monitor - which may be no surprise, but thought I’d mention it. The issue still remains with the original Toad instance, when I close and reopen that window, it’s still off-monitor.

I use Ditto clipboard utility - in the Editor, I highlight a word, open Ditto, select an item and paste it. Editor window disappears behind other windows. This is the scenario I was unclear about earlier, butI can reproduce consistently.

Hey Dale,

My situation is when I connect remotely to my work computer - I’m connecting via VDI to a terminal server, then RDP to my desktop.

This may be a bit tough to diagnose given the complex nature of your connection. There’s a lot of display translation that’s happening between those three computers (your local, the VDI connection, and the RDP connection to your work desktop). I suspect one of the connections in that chain is telling the remote computer that there are more monitors available to use than there actually are, even though they are not being displayed. A couple things you could check are:

  1. If you’re using persistent VDI connections, make sure your RDP client is up-to-date. If your connection is non-persistent, it wouldn’t much matter as it’d be restored back to its original state when you log out.

  2. Make sure in your RDP connection’s “Display” settings that you uncheck the box that says “Use all my monitors for the remote session”, as in the following:

RDP_Display.png

  1. Check your VDI connection’s “display” settings to make sure the connection is defined to only use a single monitor as well.

  2. When you RDP to your desktop, right-click on the desktop and go to your display properties to see how many monitors it’s reporting. It should only report one.

On the other issue with windows losing focus, are you working on the current beta, or is this happening in an older one? I did see your other comment about using Ditto clipboard manager, so I’ll see if I can test with that locally. In the meantime, lemme know what you find about your connections and if that helps the situation at all.

Thanks!

-John

Hey Dale,

I’m not able to reproduce this issue. I just tried a series of tests using Ditto clipboard manager with the latest beta (13.0.0.25) in SDI mode. I had copied a few things onto the clipboard, and then I opened an editor window, typed some text into it, highlighted a section of text, pressed Ctrl+` to launch Ditto and double-clicked one of the items on the clipboard. I tried this about a dozen and a half times with different permutations of selected text, items in Ditto, and Toad sessions, but each time it simply replaced the highlighted section of text without sending the editor window to the background. If you’re doing something different, feel free to let me know the exact steps you’re doing to replicate the issue.

Interestingly, when I pressed Ctrl+`, clicked on Ditto’s ellipsis button to access the menu, and then selected “Global Hotkeys”, the Ditto window itself jumped to the background each time and Toad stayed in the foreground. I then had to click on the “Ditto” application icon to bring it to the front.

One thought is if you’re accessing the clipboard items directly rather than the method I used above (some older tutorials for Ditto make references to using Win+1, Win+2, Win+3, etc to access clipboard items directly), you may want to make sure those shortcuts aren’t already registered with Windows to perform a different action. For me, pressing Win+3 launches Windows Media Player, and Win+4 is for my default browser. I’d also check Ditto’s Global Hotkeys menu to see if there are other hotkeys that might be registered which might be interfering with it pasting clipboard items into Toad.

As a last step, try resetting your user files under Utilities -> Copy User Settings. Perhaps something in the GUI settings is causing this issue with Toad – resetting the user files may resolve the issue.

Lemme know what you find.

Thanks!

-John

Thanks for your effort, and sorry to say I cannot currently reproduce via Ditto either, so I’m not sure what’s changed. I had it happen a couple time when using my PC directly and once when connected remotely.

But I can reproduce another way.

I have 2 SDI windows, Editor and SB. In SB, treeview, I display a LARGE package body (> 21000 lines). If I click away to another application, doesn’t seem to matter which one, when go back to SB and click on the Refresh all object button, it takes awhile but eventually it will display the body and then the Editor window will come to the front. The changing focus issue still happens in other scenarios, but this is the only one I’ve found I can reproduce consistently. Almost seems like a timing issue, since it only happens for packages that take a noticeable amount of time to display. It happens sometimes going between spec and body, but it’s not as reproducible.

Regarding your VDI/RDP suggestions:

  1. not sure. If it’s important to know persistent or not, I can contact SA

  2. RDP was set to “use all monitors”. I’ve unchecked and restarted a couple times. Has not solved the problem.

  3. VDI was already set to Full Screen. My setup doesn’t work with All Monitors. I haven’t experimented with Window-large, Window-small, or Custom options.

  4. Display properties show only 1 window which is identified as “1”

Regarding the other issue, besides the reproducible scenario I sent earlier, whose impact is fairly innocuous, I have another scenario which a bit more of a problem.

In the Editor, while typing, the pick-list pops up and is still processing while I type. As I continued to type, eventually the Editor window disappeared and one of my SB windows came to the front. I don’t know how many times the pick-list window popped up - probably more than once. I don’t have “check syntax as you type” checked, but have most other options checked. I’m unchecking Expected Tokens for now - the pick-list seems to be a bit more invasive currently, but that’s a separate issue.

When Project Manager window is not visible, I have no way to get to it. It doesn’t appear in the Window Bar so I can’t maximize it.

Here’s hoping you have some other ideas on your side or my side.

John, I’m using .44 and I see that the SDI windows now show up as separate items on the task bar and are movable. This works great - thank you. I haven’t installed .46 yet, so if the following are fixed there, my apologies.

I still have issues with Project Manager and Output windows, as they see to be treated differently, and I have no way of maximizing or moving them.

The focus issue still happens, the biggest pain being Session Browser - when a refresh takes a while, window sometimes disappears behind one or more windows.

Hi Dale,

We did make a few changes recently to help fix some lingering issues with SDI. I’m glad it’s working a bit better for you – at least where separate items on the task bar are concerned!

The Project Manager and Output window are not standard windows, but “dockable” windows that can be docked to a dock site. As a result, there’s no way to maximize those windows other than to resize / re-position them manually. However, there should be an option to allow you to have your positions and sizes for those dock sites persist between Toad sessions. As a result, I’ve added an option to the Options -> Startup tab for Monday’s beta that when deselected will persist your floating dock sites in SDI mode.

As for the window defocusing issue, I expected that would have been corrected in recent betas. You mentioned “when a refresh takes a while”: what other windows do you have open at the same time? Is there a common window open each time it happens? And are you still seeing this with other windows too, or are you just seeing it with the Session Browser?

-John

I almost always have several Schema Browser and Editor windows open. This last time it happened, my current Session Browser window dropped behind several SB and Editor windows. It also happens when I pop up a Describe window. From Session Browser do an F4, Describe window pops up. It seems that when the Describe window takes longer than a few seconds to fully refresh, it will disappear behind SB, Editor, and Session Browser windows.