Toad World® Forums

14.1.73.858: Can not open packages

Hello,

i am currently testing the newest Beta version, but i can not open packages in any way.

Not by clicking "CTRL+Mouse Left" on a package name, not with "Open in Editor" in the Schema Browser and it also does not work when i drag and drop a package from the TeamCoding Manager into the Editor.

I am using a Oracle 19 database with an installed Teamcoding for SVN.

I think it will be a local issue on my side, because if not, someone else would have already discovered this problem.

Is there any log file or so where i might see an error, which tells me why toad can not open the package?

BR, Julian

I'm thinking that Team Coding is blocking this, but I'm not sure why. I just tested opening packages in beta in a Team Coding environment and it worked OK for me.

Our team coding guy should be online soon.

Are you sure it is set up correctly in the beta?

You can turn on Spool SQL to see the queries that Toad is executing in the background. It may reveal something. From the main menu: database -> spool sql -> Spool to screen.

Hi Julian,

You can also try turning on VCS Debug logging by going to Team Coding -> Configuration -> User Settings -> Logging. This may help identify if, perhaps, you enabled checking out objects on opening and there was some kind of error being returned by SVN.

The only thing I can think of in Team Coding that would prevent opening items is if you were presented with the Check-out object window and pressed Cancel; however, it sounds like you're not seeing that window at all.

You can also try disabling the "Check-out object on opening" option in Team Coding -> Configuration -> User Settings to disable that option entirely. Objects opened in the editor will simply require being checked out before you compile them, which Team Coding will prompt you to do anyway.

I'd try turning on Spool SQL as John Dorlon suggested and also turn on VCS Debug logging to see what's happening behind the scenes when you're trying to open an object in the editor. If neither of those help, try turning off auto check-out on opening and see if that helps solve the issue you're seeing.

-John

Hi,
I'm also having this problem.
Would it be of any help a video file with problem manifesting?

Hi Mihai,

Are you using Team Coding in your environment? If so, what VCS provider are you using? Have you turned on VCS Debug logging and do you see any errors in the log?

-John

@mihai.petcu @gjl
Did this just start happening in Beta 14.1.73.858? Was it working fine before that and does it work fine in 14.0?

Yes
15 chars is a must

I don't understand. What do you mean by this?

I just wanted to answer a short "Yes" but I can't.
Sorry, for that.

Hi Mihai,

Which question was your "Yes" in response to?

-John

This just start happening in Beta 14.1.73.858

Oh, haha, yes because the forum doesn't like one-word answers!

I have an idea of what caused this problem. I am undoing that change for next beta (should be monday)

Super.
I can provide a short video if it helps.

Also I've noticed another issue not related with this.
Should i post a new issue, right?

Sure, post a video if you don't mind.

Also yes please make a separate post for the other issue. It makes conversation easier that way.

I tried but i can upload only (jpg, jpeg, png, gif, log, txt, sql, pdf, el of 4MB.
I have an .mp4 of 3MB.
Converted it in gif.
It would be nice if I could upload a video!

Later edit: i've replaced uploaded gif with link to video.
https://files.fm/f/bnz9th43p#

Hi John,

i think i also experienced this problem in an earlier beta version of Toad 14.1!
But in the official release of 14.0 everything is working fine.

Best regards,
Julian

Hi Julian and Mihai,

If you can, feel free to try out the beta that will be released a bit later today. We suspect that may fix this issue. Let us know if that addresses this issue, or it the issue still persists.

Thanks,

-John

Yes, now it's working.
Thank you.

Hi all,

after I completely reinstalled the Beta version it is working now also for me.

Thanks,
Julian