Toad World® Forums

Can't navigate between editor windows with multiple connections


#1

In Toad 13.0.0.80, with ‘Show Buttons for Current Connection’ selected, intermittently, when I open a new connection, I can’t navigate back to the windows of the first connection. I have to close the second session, in order to get back to the windows in the first connection. Sometimes it works, sometime it doesn’t, I haven’t figured out what specifically causes the problem. Any ideas?


#2

Does exactly what it says on the tin :wink:

If you enable “Show Buttons for Current Connection” you would have to switch back to the first connection to see it’s windows again. That is what the option literally says. If you cannot switch between your connections you may have hidden your connections toolbar (right click on a toolbar and check for “Connection Bar”).

EDIT: Sorry, just tried that in SDI mode and can reproduce your exact problem. Open Connection 1, see the Editor, open connection 2, switch back to Connection 1 -> No Editor Button and SDI Editor still shows “Connection 2” in its title.


#3

Does it start working normally after you open a window for the 2nd connection?


#4

Seems to be only an issue with the Editor.

I tried the following:
Open C1 -> Editor for “C1”
Open C2 -> Editor for “C2”
Switch to C1 -> Editor stay for “C2”
Open SB in C1 -> SB “C1” opens, still no Editor “C1”
Open Editor in C1 -> Editor “C1” opens, Editor “C2” stays, SB “C1” stays

Also tried:
Open C1 -> Editor for “C1”
Open C2 -> Editor for “C2”
Switch to C1
Open Editor via toolbar -> Editor for “C1”
Switch to C2 -> Editor still for “C1”

Seems like the Editor is tied to the last instance which opens an Editor. And yes: Except if there is another window open.

PS: Just tried this on 13.1.0.64. Also: I have the Editor set to “One/Connection” in the options. Maybe that’s related?!


#5

This is what I found, is it the same as what you are talking about?

  1. ‘Show Buttons for Current Connection’ checked.
  2. open a connection and an editor. Maximize the Editor.
  3. open another connection, but no windows.
  4. problem -> as you click back and forth between connection bar buttons, the window bar button for the editor disappears.
  5. open editor (or any other window) for 2nd connection
  6. now when you click from one connection bar button to the other, all is well.

I have this fixed for 13.2 beta #1.


#6

No, this seems to be another (maybe related) problem, which I could not reproduce foy myself, because if I maximize the Editor window, I can’t even switch to the Toad “main” window (with the toolbars) to switch the session. The Editor stays on top.

After some more testing, I am certain this is a bug with the “One/Connection” option in View -> Toad Options -> “Window” pane.

Toad in SDI mode, “Show Buttons for Current Connection” enabled, “One/Connection” option for Editor enabled: If you open just the Editor on multiple Connections (e.g. by enabling “Auto open” or by specifically open it via Toolbar), the editor opens just once for all connections, except when there is another window open for a specific connection.

Toad in SDI mode, “Show Buttons for Current Connection” enabled, “One/Connection” option for Editor disabled: Opens an Editor for every connection, regardless of any other open windows (= expected behaviour).


#7

Oh you are in SDI mode. I was in MDI mode.


#8

Yes, thought OP was also, wrote a sarcastic reply, then I realized he was talking about SDI, too :wink: MDI always worked fine with “Show Buttons for Current Connection”.


#10

Another clarification: During my tests I always had “Auto Open” option enabled for the Editor. So for every connection opened in my test there was always an Editor auto opened. Behaviour is the same if I disable “Auto Open” option and open Editors manually, though.


#11

OK, just so everyone is clear - MDI mode is when windows are contained within main Toad window. SDI mode is when windows float all over the place.

I had a big reply typed up, then saw your edits, then realized that my current dev build is behaving differently than 13.1, and Wendy is talking about 13.0 anyway, so I probably need to check that too.

I’m done for the day, will start on this again tomorrow. :slight_smile:


#14

I see this problem in 13.0 and 13.1 with “One/Connection”, but only in SDI mode.

  1. make connection 1, open editor
  2. make connection 2, open editor.
    problem-> 2nd editor does not open. Instead, first editor switches connections.

I’ll log this and fix it. It seems different than the original problem though. @wpenfoldithaca.edu Wendy, if we haven’t found your problem yet, please let us know.


#15

I think I’m working in MDI mode–all my windows are in the main toad window except for the describe window. When I open a new connection, it automatically opens an editor window. I currently have four connections open. Connection 1,2 and 4 are functioning normally. Connection 3 shows an editor window in the window bar, but if I click on it, it sends me to the editor window of connection 1, and if I try to open another editor window for connection 3, it opens it instead under connection 1.


#16

Hi Wendy, thanks for the details. I tried your steps and it is working OK for me. I guess you did say that it was intermittent. If you zip up and email me your user files folder I’ll try again. john.dorlon@quest.com


#17

Exactly, and with “Button for Current Connection” the Editor Button just disappears for the first Connection.

Glad this got sorted out and will be fixed (I can hardly work without “One/Connection” and “Button for Current Connection” after some years being used to it). But it is too late now for a fix in 13.1, right?

Thank you and sorry for the confusion caused :wink:


#18

Yes, too late for 13.1, but 13.2 betas will start up soon after 13.1 comes out, so that’s an option.