[] Slow performance in Editor

Hi guys!

in the beta version i am experiencing performance issues within the editor.
I am editing packages with sometimes ~5000 rows and when i select a text by double clicking it, the editor needs some time to load.

Also when i am pasting code into the editor, it hangs for a short time.

I have no problem with 16.3 version and some beta versions ago there was also no problem. Maybe it is because of the new navigator in the editor.


Thanks and BR,

Right-click on that simple navigator and turn it off to see if things improve and let me know. It can be re-enabled in Options on the Editor | Display page.

1 Like

I am using currently. I have had the same exact problem with every Beta since passing my last stable version which is Turning off navigator dramatically improves the long load time. I look forward to its resolution.

Brad Clark

Hi Brad,

When you say "Navigator" do you mean the regular navigator or the new Simple Navigator in Julian's screen shot?

If regular navigator, try this:

  1. Update to latest beta
  2. Turn navigator back on
  3. Right-click in navigator and uncheck "Show references" (this will only make a difference in performance in last couple of betas, hence step 1)


After posting I noticed the newest release and installed it.
Unchecked show references in navigator options as suggested.
Issue resolved! Thanks!

1 Like

@gjl Julian, I think unchecking the "show references" option will help you too.

Hi John,

i just made the changes described from above.
The performance issues were not noticeable all the time - it was just lagging some times. Because of that i won't see it directly if it get's better.

Let's see if the issue gets resolved with this.

Thanks and BR, Julian