Toad World® Forums

4.0.1 Import Export Wizard - will not open

This is a strange problem I was hoping you could help us with. TDP was upgraded to 4.0.1, and the Import / Export wizards aren’t working at all under our primary Windows account.

The symptoms are that we’re unable to open TIM or TXP files, unable to open Import Export from menu, and unable to create import or export templates from automation. Any time one of these actions is taken, nothing happens.

Import Export functionality is working in 4.0.1 only under the admin account the version was installed from. It was installed for all users. With this being the case, it seem like a permissions issue, but unsure for what, as there are no errors.

Thanks!

It is possible that an error is being suppressed that might help us understand what is occurring. Please go to Help | about | AppDataDir.

Then open the Knownexception.xml file and delete the contents as shown in the second picture. I have included a before and after pic. Then please stop and restart TDP and try to open file. You should get a pop-up error. Please post screeenshot and also post our exception file name ExceptionTrace.log.

Thanks Debbie for your reply and assistance.

Here’s an example of the error - it’s occurring when attempting to open import or export templates, as well as when attempting to create a new template.

System.ArgumentException
The path is not of a legal form.
Stack Trace:
at System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32 maxPathLength, Boolean expandShortPaths)
at System.IO.Path.GetFullPathInternal(String path)
at System.IO.DirectoryInfo.Init(String path, Boolean checkHost)
at System.IO.DirectoryInfo…ctor(String path)
at Quest.Toad.ImportExport.ImportFileBrowserControl…ctor()
at Quest.Toad.ImportExport.ImportWizard.InitializeComponent()
at Quest.Toad.ImportExport.ImportWizard…ctor(String filename, Connection conn)
at Quest.Toad.ImportExport.ImportWizard.Import(String filename, Connection conn)
at Quest.Toad.Analyst.AnalystActionManager.OpenImportTemplate(String file)
at Quest.Toad.Gui.MainForm.OpenFile(String file, PredefinedParameterCollection predefinedParameters, Boolean supressLibraryAdd)
at Quest.Toad.Gui.MainForm.openFileButton_ItemClick(Object sender, ItemClickEventArgs e)

Untitled.jpeg
ExceptionTrace.log (152 KB)

I ended up installing 4.1 64-bit, and it’s having the same issue, as well as versions down to 3.4.

Can you post one of the import template files that are having issues? Also, try opening them using Tools | Import Data | Open Template.

Does this also give the same error?

opentemplate.png

Hi,

can I ask you if you can provide to us what operation system do you use? Seems that problem come when we try initialize your “MyDocuments” folder in Import wizard. This usually happen if you are using older OS (Windows XP or older) or if your account don’t have access (for read and write) to this folder. Can you try create new folder in your MyDocuments? Are you able run Toad as administrator (right click on Toad.exe -> Run as Administrator) and test it for us?

Thanks

Filip

Or does the file path contain any Unicode chars?

Debbie & Filip,

Thanks for the additional details.

We’re on Windows 7 Enterprise 6.1 Build 7601 SP1

The path shouldn’t contain any special characters - we have all files either in C:\sql or c:\temp

Selecting Tools | Import Data | Open Template from the file menu results in the same error above. I’m attaching an example TIM on the next post.

The details about initializing “MyDocuments” could be related - we’ve experienced an issue with a network share which also contained Documents, Recycle Bin, and other such folders. Not sure if “MyDocuments” may be linked somehow to the share which is currently inaccessible. We’re currently working on restoring access to the share, and offline files were cleared.

Is the need to initialize “MyDocuments” hard coded into the application? I’ve looked for any path-related settings in the AppData files and registry, and nothing stood out. I also looked for any folder redirection keys in the registry, and it was difficult to determine if any are related. Regardless, policies may override.

Thanks,

Michael

Example TIM attached. Renamed to txt to upload.

Another thing we tried was downgrading .NET 4.6 to 4.5, and this didn’t change any errors (of couse - assuming 4.6 should be backwards compatible).

Various versions of TDP we have from 3.4 - 4.1 are able to create and open import/export templates no problem, but only under an admin account on the PC. Unfortunately, we’re limited to using a user account due to company policy.

Thanks,

Michael
test.txt (1.53 KB)

This import file is using a csv file to import. -->FileName="C:\Temp\cpe_auto_cap\test\compile_cpe.csv" It looks like we are trying to open the file. If the file does not exist you would see this window. Instead you say it errors. Does this file exist on pc with logid where it errors. Can you open the file outside of TDP? Is this a share environment such as Citrix? Debug this file access seems to be what is needed.

Debbie,

While answering your question, I’d like to add another piece of the puzzle:

In the example above, the compile_cpe.csv file does exist and can be opened in Excel, etc. Not only that, but the import runs successfully. However, when attempting to edit the template, the errors in my first second post appear - same as when attempting to create a new template. Also, this import template and all the others work (and edit) without error [only] from an admin account.

Our issue is isolated to one user account & PC, and all versions of TDP tested (3.4,3.7,3.8,4.0,4.1x64). The primary challenge we face is that in order to maintain, update, or create any templates, they have to first be transferred to (or created on) another account/system and then transferred back in order to run on this dedicated system and account for automation.

Filip’s question about “My Documents” was interesting, however the primary “My Documents” links have full access, as expected. It’s possible that there could be an unknown issue with the user profile, and we’re in queue to re-create the profile, which is looking like next year. It’s just a toss of the dice.

Thanks,

Michael

I think you are on the right track. I made import script and exported csv as admin user. Then loged on as user in the USER group. I did not get any errors. What group is your user in? To change you may have to get your IT to help as you mentioned.