Toad World® Forums

6.6: How to disable formatting upon save of a stored procedure?

How can I stop Toad from automatically formatting my SQL when I save a script?

Ideally, I’d like to disable the formatter completely. (Yes, I know I can customize it, but not nearly enough.)

Hi Mark,

Sorry, I don’t understand this problem. I try to save stored procedure as script, or create procedure, or alter procedure, but all the script not change the formatting.

Could you please kindly provide us more specific step?

Kelly

Two use cases:

One:

  1. Right-click on a stored procedure in the Object Explorer pane and select Details.

  2. Select the Script tab.

  3. The code shown has been reformatted by Toad, not as it exists in the database.
    Two:

  4. Right-click on a stored procedure in the Object Explorer pane and select Alter Stored Procedure.

  5. Make any change.

  6. Select the SQL Script tab.

  7. The code shown has been reformatted by Toad, not as it was in the General tab.

  8. Select the General tab and you will see the code with the original formatting is still there.

Hi Mark,

Thank you for your detail. In Alter Sotred Procedure Script tab, there is a option Auto fomat can disable the auto formate.

Kelly