Toad World® Forums

10.1.1.8 Disable Formatting


#1

My procedures and functions are all formatted the way I want them.

But in the SOURCE TAB on the RHS, the code is always reformatted.

How do I disable the TOAD formatter altogether?


#2

Right click on a procedure in the LHS. Uncheck “format source”.


#3

To disable formatting in the source tab for procedures, R-click in the left hand
side of the Schema Browser while in the procedures tab and uncheck “format
code”. You can do this for other SB tabs as well.


#4

Thanks!!! This was driving me nuts! So much better.


#5

To disable formatting in the source tab for procedures, R-click in the left hand
side of the Schema Browser while in the procedures tab and uncheck “format
code”. You can do this for other SB tabs as well.

Not in the Views tab. That’s really irking me.


#6

You can in 10.6 – open the options dialog (from the Scripts page toolbar
in the browser) and uncheck ‘Format’ on the Views tab.


#7

You can in 10.6 – open the options dialog (from the Scripts page toolbar
in the browser) and uncheck ‘Format’ on the Views tab.

THANK YOU! You just saved me a world of headaches.


#8

If you don’t like what Toad is doing, there’s usually an option to
configure the behavior. It can be tricky to know where to look is all.


#9

Yes, thanks for the tip. For those who may have a hard time figuring out just how to do that, here are more detailed instructions: While viewing the script in the Script tab (no matter how you get there), click the toolbox icon just below the Script tab itself (mousing over the button show tooltip “View/edit script options”). This opens the Script Options dialog. Click the Views tab, uncheck the Format option, and click OK.


#10

Hi,

I find that this still does not work. It does minimize the effect, but TOAD is still formatting my code. I just want it to leave my code alone. I find that the settings in Formatter Options, Alignment, DML Statements have control over my code even when I have followed the aforementioned steps of going to the Script Options, Views tab and unchecking “Format”. Isn’t there some way to turn this completely off???

Thanks,
Paul


#11

P.S., I am using TOAD for Oracle 10.6.1.3. Sorry for the omission.