Automation Designer and Task Scheduler

I used Automation Designer to create an action, which I am able to run successfully (it runs a sql file and creates/saves an Excel file. But the scheduling piece doesn;t work - it returns the error message: "The system cannot find the file specified"
What am I missing?

It's hard to say without more info. Can you post a screen shot of your actions and also let us know which version of Toad you are using?

Do you know if the error refers to your script or the output?

Do you have any variables in in your path to these files? Does it help if you remove them?

the action executes correctly, but the scheduler encounters an error:
(not sure if the above image displays here)
I'm using Toad 16.3, and in Action Details, toad.exe is the application, the parameters: -a "FOS 850+ Weekly->Export Dataset1", and the Work Dir is empty
Thank you

Can I see the a screen shot of your export dataset action?

Specifically where the SQL and Output files are specified.

I don't think the problem is the scheduler itself. I think it is either
a) some variable that can't be set when running as scheduled which is causing Toad to not be able to find (or create) a file.
b) the windows scheduler can't find Toad

Where are you seeing the error message? Can you post a screen shot of that too?



S is a network drive, I assume.

The scheduler probably can't get to it.

Does it work on c:?

it does not. I changed both the location of the sql file and the extract to C:. .The Export action on automation designer works, but the scheduler does not

@bastak , there's a plus sign in your filename. Don't think windows allows a plus symbol in a file name. Do you want to try without this symbol? I have scheduled something similar at UCL with network drives and they work fine.

Hope this helps you.


oh, Thanks I tried that but still no result. The automation runs, but the scheduler does not, even with the revised file name. I also changed the task name, with no effect

Maybe some different settings in here will solve it?

Yes, check the user permissions, but also double-check that the Task Scheduler has the correct path to your Toad.exe.

I ran it with that option checked, but still get same error: the system cannot find the file specified.

I checked the pat and it is correct. to make sure, I copied the path from my shortcut, and it is the same. I'm not clear what user permissions you refer to. database permissions are valid.
My parameters are: -a "FOS 850plus Weekly->Export Dataset"
Do I need to specify anything in work dir?

Was referring to windows account user permissions, per Mr. Dorlon's previous reply, not DB user perms.

Sorry, I didn't mean try try it with the exact settings as in my screen shot. I meant - whatever you have there, try something different to see if that helps. Also try "run with highest privileges".

It does seem like windows scheduler cannot access Toad.exe. If Toad had some problem running the action, it wouldn't write an error message there. It would be in the Automation Designer log.

You can also go to Windows Task Scheduler and locate your scheduled task. On the right side Actions menu make sure you "Enable all tasks history" and then rt-click and Run the task from there. After it runs/fails view the History tab at the bottom. When I setup a scheduled task that will fail there is additional info there with the reason for failure.

thanks. I did that and see no error: