Toad World® Forums

Automation

I have 4 automation scripts which run every night and feed 4 excel files. Yesterday I decided to organive the scripts into folders (one folder for each .tsm and .tas grouping) so that they would be easier to find (Still on the same drive in the same master folder), and I kept the excel files in their same locations. I also made sure to repoint the links in all of the automation scripts to the TSM files. When I look at Job Manager, it says that all 4 ran last night, but the Excel files haven’t updated. These tasks have been running just fine up until today, so I feel pretty sure that the reorganization is what caused this issue. How do I fix it?

Hi,

How do you execute the scripts? Do you use TIC Scheduler and execute the scripts on TIC server or execute them locally using Windows Task Scheduler?

Could you run a script manually and send us the log file?

Regards

Aleksey

I use the scheduler built into toad. It worked perfectly when I ran it just now.

This what the Job Manager looks like:

And these are the files that are supposed to load.

StaffID’s is the one I just ran.

ClientRun.tas feeds ClientDemos

ProdExport.tas feeds ProductivityRaw

and AutoToadBill.tas feeds WelligentCurrentFY

ActivePaysource.tas is set to only run on Mondays and Wednesdays.

Hi,

Could you clarify couple questions?

Have you run the scripts manually directly from Toad without scheduling them? Were the scripts executed successfully and populated Excel files?

Regards

Aleksey

I didn’t test run them all after I made the changes yesterday, I’m doing that now. I have only the largest one left and so far they’ve all run fine. That wouldn’t explain why it said they were run when they weren’t though.

I’m assuming “run fine“ means that the new Excel files are populated correctly.

Now you have to reschedule the scripts again to be sure that the Job Manager uses the correct scripts.

That is correct. If they don’t run tonight, I’ll reschedule them.

I did re-schedule them all yesterday, and the same thing happened again. Job Manager says that they all ran last night when they were supposed to but the excel files weren’t updated.

Did you delete the old schedule and create a new one from the opened .tas file with your linked file changes in it?

a real test would be not to run (Test run) but schedule it to run now.

No. I went through Edit in Job Manager.

I’ll try that later when I get some time.

I had a problem like that in version of Toad (forgot which) where the job manager did not update the job in windows scheduler. I think it was deactivate that did not work. I would go into Windows Scheduler and you could see that the job manager change did not take place. Job manager just packages up all the scheduling information and passes it to Windows scheduler (makes it easy) but you may have run into an update problem. Never had problems on a new schedule though.

Greg the issue you mention with deactivate a task was an exiting error. We decided to fix it by upgrading the job manager to use the newer style task scheduling. this will be available in the next Beta.

Paul, what does the automation logs say? And what is the return code on the window task scheduler (use the one from the operating system)

Here is a video I made a long time ago about how to debug an automation script.

www.toadworld.com/…/1120

See if that helps. If not, I can get deeper into debugging this.

I got the “0x6F” error on the Task scheduler for all. I have 10 now because I recreated them all in an attempt to correct things. I tried to go through the troubleshooter, but I can’t get into toad. I got this message:

I was unable to get on on Friday all day with the same message.

The error code means there was an error but the script continued. I would suggest you add exception emails or at a minimum add an email at the end of the script that also sends the full log file. I go over how to do this in the video I referenced earlier.

I’d like to try some of these things you’re suggesting, but every time I try to connect for the last 3 days, I get the connection timeout message, do you have any suggestions for that?

Try increasing your time out values. They are in the options under Database | Timeouts | Connection Timeout

According to our IT, the problem has to do with our EHRS vendor Welligent. We upgraded our internet and that messed with our connection to Welligent. Something about our URL’s. We’re waiting for Welligent to do something on their end. Do you have any insight with that end of things?